Importing New Schedule [SOLVED]

I changed over to my winter schedule, by importing it via my sql. I did this before, but now I get these errors?!

Warning: move_uploaded_file(/home/woodsdom/public_html/CPC/core/cachecpc_schedules_Jan25.csv) [function.move-uploaded-file]: failed to open stream: Permission denied in /home/woodsdom/public_html/CPC/admin/modules/Import/Import.php on line 233

Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to move ‘/tmp/php3HLTc1’ to ‘/home/woodsdom/public_html/CPC/core/cachecpc_schedules_Jan25.csv’ in /home/woodsdom/public_html/CPC/admin/modules/Import/Import.php on line 233

Warning: fopen(/home/woodsdom/public_html/CPC/core/cachecpc_schedules_Jan25.csv) [function.fopen]: failed to open stream: No such file or directory in /home/woodsdom/public_html/CPC/admin/modules/Import/Import.php on line 235

Warning: fgetcsv() expects parameter 1 to be resource, boolean given in /home/woodsdom/public_html/CPC/admin/modules/Import/Import.php on line 251

The import process is complete, added 0 schedules, updated 0, for a total of 0

Warning: unlink(/home/woodsdom/public_html/CPC/core/cachecpc_schedules_Jan25.csv) [function.unlink]: No such file or directory in /home/woodsdom/public_html/CPC/admin/modules/Import/Import.php on line 404

What have I missed?! I now have no schedules

When I try to use the admin panel, I get the above errors. When I manually add it into the SQL database, it seems to drop the CODE from my CSV file. Because of this, everything gets moved out of place. I have NO idea why this is happening this way. I can’t figure why it would drop a field from the CSV file?!? Please…someone help, if you can. Thanks.

Right.. read the error messages:

Warning: move_uploaded_file(/home/woodsdom/public_html/CPC/core/cachecpc_schedules_Jan25.csv) [function.move-uploaded-file]: failed to open stream: Permission denied in /home/woodsdom/public_html/CPC/admin/modules/Import/Import.php on line 233

Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to move ‘/tmp/php3HLTc1’ to '/home/woodsdom/public_html/CPC/core/cachecpc_schedules_Jan25.csv’ in /home/woodsdom/public_html/CPC/admin/modules/Import/Import.php on line 233

Check file/folder permissions.

Yep that’s what i had folder needs to be 777

I have. Believe me, I don’t understand why it is doing it?! I had a server crash a couple months ago and all was corrected, to my knowledge. But I am having an issue now with this updating of the schedule. I assume you mean the core/cache directory for permissions. It is set correctly?!

Yep but if i remember right i had to do the core folder as well to get it to work that was after my server crash

Even if you just temporary update that folder and change it back after the import which is what i did.

AWESOME!!! That is EXACTLY what I did. Changed the core file permission, uploaded the csv file, and changed the core folder back. Thanks a MILLION… pun intended

Now, from what I see…I will have to change the core directory permission to 777 every time I update the schedule?! Never had to do that before. Is there something from my server crash I am missing then???

Yep, who is the owner of your folders, should be www-data or something like that. I have left mine alone as i have enough problems so its working thats good enough for me :)until i get adventurous and start tinkering about and mess it up again.