SettingsData.class.php - please help

Hello,

as you can see at www.travelservice-virtual.net I’d like to install phpVMS, but it shows this error:

Fatal error: Class ‘DB’ not found in /var/www/vhosts/travelservice-virtual.net/httpdocs/core/common/SettingsData.class.php on line 28

Please, can you help me, where I have to search mistake ?

Thank you, Michal Kozel

Reupload the phpvms, the file is missing or currpoted

Yes, I did it before, but it doesn’t help and on FTP client i normally see this file

Yes, I did it before, but it doesn’t help and on FTP client i normally see this file

i’m not really sure, now. Sorry, i’ll leave this to Nabeel or someone will help you.

Can you post the output from /install/checkinstall.php?

phpVMS Virtual Airline Administration Software

Install Check

phpVMS Build Number: 934

Checking PHP version

[OK] PHP version is 5.2.13.x

ASP Tags

[OK] ASP-style tags are disabled

Checking connectivity…

[OK] Can contact outside servers

Checking for SimpleXML module…

[OK] SimpleXML module exists!

Checking file hashes for corrupt or mismatched files

[OK] No errors found!

– Checked 183 files, found 0 errors

Make sure the core/local.config.php file has a filesize of 0 and is completely empty before you run the installer

Hello mates,

the problem resolved but after begining the installation steps another probelm occured

Warning: Creating default object from empty value in… and many other error message appears on top of website … e/classes/Vars.class.php on line 74 Strict Standards: Accessing static property PilotAdmin::$post as non static in /home…/CodonModule.class.php on line 67 Strict Standards: Accessing static property PilotAdmin::$get as non static in /home/…

it’s a long message.

looking forward,

waiting for an answer to start my project pls

What is your php version ?

last version on website

I do not mean phpvms but php

Have a look here

http://php.about.com/od/troubleshooting/qt/php_version.htm

sorry for misunderstanding, php version 5.4.28

Phpvms works without problems until Php 5.3 after this there might occur some problems

have a look here