Jump to content

PopUpNewsModule


simpilot
 Share

Recommended Posts

  • 1 month later...
  • 1 month later...
  • 4 weeks later...
  • 7 months later...

I've downloaded the module from github, but when accessing index.php/PopUpNews/ I'm getting the following error:

Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'PopUpNews::index' was given in /home/****/public_html/rot/core/classes/MainController.class.php on line 218

Any workaround?

Link to comment
Share on other sites

  • Administrators

I've downloaded the module from github, but when accessing index.php/PopUpNews/ I'm getting the following error:

Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'PopUpNews::index' was given in /home/****/public_html/rot/core/classes/MainController.class.php on line 218

Any workaround?

What code are you using to call the module in your template?

Link to comment
Share on other sites

On the frontpage it is called with:

<?php PopUpNews::PopUpNewsList(5); ?>

While clicking on the link (title), I'm being sent to index.php/PopUpNews/popupnewsitem/2 or other number. I thought that if I'm trying to access index.php/PopUpNews/ I'll land on a page where all the news items are shown. But it seems that this is not possbile.

Link to comment
Share on other sites

  • 4 months later...

Hello, I have this error showing up just recently on the PopUpNews module.

Strict Standards: Non-static method PopUpNews::PopUpNewsList() should not be called statically, assuming $this from incompatible context in/home/xlavacou/public_html/en/lib/skins/XL VA/frontpage_main.tpl on line 73

Strict Standards: Non-static method PopUpNewsData::get_news_list() should not be called statically, assuming $this from incompatible context in/home/xlavacou/public_html/en/core/modules/PopUpNews/PopUpNews.phpon line 24

Any help would be appreciated!

Cheers :)

Link to comment
Share on other sites

  • 5 months later...
  • Administrators

If you are positive that the module is installed correctly then you have probably downloaded the latest version of the module which uses the template extension of .php instead of .tpl as the latest development version of phpVMS is using. You can find the last release of the old style templates under the releases tab at github.

I would also suggest using the PluginManager as it will download the correct version according to your system and also install it all automatically. You can find it here -> https://github.com/DavidJClark/phpVMS-Plugins_Manager

Link to comment
Share on other sites

  • 4 weeks later...

G'day Simpilot,

I recieve the message below on my site,

Latest News

Notice: The template file "/home/qantasvi/public_html//core/templates/popupnews_list.tpl" doesn't exist in /home/qantasvi/public_html/core/classes/TemplateSet.class.php on line 248

PopUpNews © simpilotgroup.com

this can be viewed on my site: http://qantasvirtual.com/

Looks like you did not put the popupnews_list.tpl file in your core/templates or skin folder.

hello

i am totally new to phpvms and its script....learning by doing now..

i had the same problem on the first quote, the answer obviously pretty clear on the second quote..but, where i can get the popupnews_list.tpl file? do i have to create it myself?

if so, can anybody show me how?

Link to comment
Share on other sites

  • 4 weeks later...
  • 5 months later...

i am getting this error

Notice: The template file "/home/flyetiha/public_html//lib/skins/Sim Widget/popupnews/popupnews_list.tpl" doesn't exist in /home/flyetiha/public_html/core/classes/TemplateSet.class.php on line 226

any ideas all files installed into the right place

Link to comment
Share on other sites

  • 1 month later...
  • 1 month later...

Hi!

I have a problem with the installation of the module. After installing jumped this message:

Notice: The template file "/virtual/regionalairlines.cba.pl//core/templates/popupnews/popupnews_list.tpl" doesn't exist in /virtual/regionalairlines.cba.pl/core/classes/TemplateSet.class.php on line 248

What to do?,

Regards

Link to comment
Share on other sites

  • 1 month later...

HI

I have a problem install the popupmenu, it shows:

Warning: call_user_func_array() expects parameter 1 to be a valid callback, class 'PopUpNews' does not have a method 'index' in /home/dragaorg/public_html/core/classes/MainController.class.php on line 218

please advise

Link to comment
Share on other sites

  • 4 weeks later...

Well i saw some one got this error but no one answered it... Now im getting this error on a fresh install of phpvms.. assuming i was using the new version of PopUpNews not compatible with my phpvms i changed it to 2.1 popupnews and im getting this

Strict Standards: Non-static method PopUpNews::PopUpNewsList() should not be called statically, assuming $this from incompatible context in /home3/vdelta/public_html/lib/.../frontpage_main.tpl on line 231

Strict Standards: Non-static method PopUpNewsData::get_news_list() should not be called statically, assuming $this from incompatible context in /home3/vdelta/public_html/core/modules/PopUpNews/PopUpNews.php on line 31

Ive never had problems with this before so i dont quite understand what went wrong... or where it went wrong

Any help anyone?

Much appreciated!

Link to comment
Share on other sites

  • 2 months later...

I got a little something odd happening.

When someone posts news and it has an ' in it, it adds a bunch of \ like the example below:

Cincinatti Holiday Returns - Now that Christmas is over and you have a pile of \\\\\\\\\\\\\\\"Pesky Unwanted\\\\\\\\\\\\\\\" Flightplans that resemble that horribly ugly Christmas Sweater and Aunt Lucille knit you seven years ago you find yourself in need of a place to return them. We can help. Any flightplans that you received this year that you don\\\\\\\\\\\\\\\'t want can be returned to our returns center on the 3rd of January, 2015 between 21:00z and 01:00z [4pm~8pm EST]. We\\\\\\\\\\\\\\\'ll be staffed up to the 9s to make sure your returns process is easy and painless so that you can get back underway with just the right flightplans that you always wanted. For further Return Policy terms and conditions, please see one of our friendly controllers. Thank you!

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Any way to make this so it don't add all those back slashes? I know it needs to escape stuff just because, but that makes the news look bad real quick.

Thanks for taking a look!

Ray

P.S.

I just noticed that it is happening in Events module as well. php5 issue? Can't use images or anything anymore. all those backslashes mess up all the code.

Link to comment
Share on other sites

  • 2 weeks later...

Nah have not reverted to an older version of php yet and I researched it and that is the issue. I have saw sever posts on other sites that say it has something to do with magic quotes or something like that. And I did some digging and it is other modules as well. I might just try reverting back to a little older php version just to check things out.

**EDIT**

This magic_quotes_gpc is most of the problem. I heard it is going away in php 6.0. As we sit now this setting renders phpVMS news and anything else that uses code useless. We need to strip slashes back out before it is printed on the site.

Good times! :-)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...