Jump to content
Vangelis

Auto Accept/Reject Pirep

Recommended Posts

With the auto accept/reject plugin I get this error

[25-Oct-2017 09:22:57 Europe/London] PHP Deprecated:  Non-static method PirepAcData::get_settings() should not be called statically, assuming $this from incompatible context in /var/www/fly/admin/modules/PirepAutoAccept/PirepAutoAccept.php on line 54
[25-Oct-2017 09:22:57 Europe/London] PHP Stack trace:
[25-Oct-2017 09:22:57 Europe/London] PHP   1. {main}() /var/www/fly/admin/index.php:0
[25-Oct-2017 09:22:57 Europe/London] PHP   2. MainController::RunAllActions() /var/www/fly/admin/index.php:83
[25-Oct-2017 09:22:57 Europe/London] PHP   3. call_user_func_array:{/var/www/fly/core/classes/MainController.class.php:218}() /var/www/fly/core/classes/MainController.class.php:218
[25-Oct-2017 09:22:57 Europe/London] PHP   4. PirepAutoAccept->index() /var/www/fly/core/classes/MainController.class.php:218
[25-Oct-2017 09:22:57 Europe/London] PHP   5. PirepAutoAccept->overview() /var/www/fly/admin/modules/PirepAutoAccept/PirepAutoAccept.php:26

Anyone know how to fix it?

Share this post


Link to post
Share on other sites

Go to PirepAcData.php in core/common and find Public Function get_settings()  and change it to  Public static Function get_settings()

Edited by Vangelis
  • Like 1

Share this post


Link to post
Share on other sites

And I also get this now 

[28-Oct-2017 16:12:55 Europe/London] PHP Deprecated:  Non-static method PirepAcData::get_criteria() should not be called statically, assuming $this from incompatible context in /var/www/fly/admin/modules/PirepAutoAccept/PirepAutoAccept.php on line 52
[28-Oct-2017 16:12:55 Europe/London] PHP Stack trace:
[28-Oct-2017 16:12:55 Europe/London] PHP   1. {main}() /var/www/fly/admin/index.php:0
[28-Oct-2017 16:12:55 Europe/London] PHP   2. MainController::RunAllActions() /var/www/fly/admin/index.php:83
[28-Oct-2017 16:12:55 Europe/London] PHP   3. call_user_func_array:{/var/www/fly/core/classes/MainController.class.php:218}() /var/www/fly/core/classes/MainController.class.php:218
[28-Oct-2017 16:12:55 Europe/London] PHP   4. PirepAutoAccept->index() /var/www/fly/core/classes/MainController.class.php:218
[28-Oct-2017 16:12:55 Europe/London] PHP   5. PirepAutoAccept->overview() /var/www/fly/admin/modules/PirepAutoAccept/PirepAutoAccept.php:26

 

Share this post


Link to post
Share on other sites

@Vangelis since i switched to 5.5 the pireps are not being accepted automatically and when they are to be rejected its not setting them as rejected but it does put a comment on them why it was rejected even though it didnt reject it or accept it they will still be apporval pending. Any Help ?

Share this post


Link to post
Share on other sites

Thanks, thought I had read in this thread it did not. I'll double check my installation and see if I did something wrong. It's only does acars right, not manual reports, and you have to have one option turned on? For instance I only want if someone flies over 1x simrate speed at this point! So what do I enter in the simrate option?

2017-11-19_1431

Thanks!

Edited by jnascar

Share this post


Link to post
Share on other sites

is this mod still available and if so, where can I get it? 

Also is it compatible with tours? I know theyre touchy with "approval all pireps", but with auto, unless 2 people submit at the same time, I guess there wont be an isse

 

 

Share this post


Link to post
Share on other sites

 

On 29/07/2017 at 12:04 AM, AJCWebServices said:

Hi 

 

 I get this error. Can anyone say if it was fixed. Cant seem to find a fix in this thread @Vangelis

 

Many thanks

Sorry to be a pain, however smartCARS is throwing the same error as the original post dated 06/12/2015 at 4:23 AM by danydj96

[08:11:17 AM] [ERROR] An unknown or unsatisfactoy response was received during the PIREP filing. It was : <br />
<b>Strict Standards</b>:  Non-static method PirepAcData::search() should not be called statically in <b>/home/topweb1/flyasia/core/common/PIREPData.class.php</b> on line <b>807</b><br />
SUCCESS

Im using phpVMS 2.1.936 until I can upgrade :)

 

 

Share this post


Link to post
Share on other sites

Hi Vangelis,

19 hours ago, Vangelis said:

edit PirepAcData.class.php and where "public function" replace with "public static function" in the line of your error .

PirepAcData.class.php only has 350 odd lines of data, but PIREPData.class.php , line 807 is between the 2 lines below

    $pirepdata['load'] = FinanceData::getLoadCount($pirepdata['aircraft'], $sched->flighttype);
        }
        
        /* If the distance isn't supplied, then calculate it */

 

Share this post


Link to post
Share on other sites

Good night, I have this error that appears when I want to enable the auto pireps module in the admin center of phpvms 5.5 and I click on save setting, I get this, help please

Deprecated: Non-static method PirepAcData::editSettings() should not be called statically, assuming $this from incompatible context in /home/worldwin/public_html/admin/modules/PirepAutoAccept/PirepAutoAccept.php on line 135

There was an error editing the Settings

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...