Jump to content

Sim Brief for phpvms


Recommended Posts

  • Replies 275
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

I know that many of you where waiting for it, i would like to thank Ashley Jones from virtualthomson - TuiVirtual for the motivitation to make it. You are free to download it at http://baggelis.com/.

Look in all files associated with this module and change all http to https. I believe yours isn't working correctly because your site is https and the sites you are attempting to access from your site

Hi ViniciusQuadros, I am also using crewcenter and never got the simbrief plugin to work. Could you please shared the complete code you are using with me to use from the briefing page?  

Posted Images

  • 1 month later...
  • 1 month later...
  • 2 weeks later...

Hi people,

im having this problem, when i generate the ofp (view example)

http://www.goldenskyva.com/crew/index.php/SimBrief?ofp_id=1520653305_9607580991

then show me this error when loading the new page of the Briefing

Notice: The template file "/home2/golderc2/public_html/crew/core/templates/SimBrief/SimBrief.php" doesn't exist in /home2/golderc2/public_html/crew/core/classes/TemplateSet.class.php on line 231

¿Anyone know about this error on the webpage?

Someone help me =(

I'm going crazy......

 

Edited by dmitri82
Link to post
Share on other sites
  • 2 weeks later...

Hello Everyone, I have an api key from simbrief and i have followed all of the instructions on the readme file that came with the module but when ever i click the generate button nothing happens..

also when i go to http://airaustraliava.com/index.php/SimBrief/ there's a whole thousand errors that have occured 

if someone could help that would be much appreciated 

 

Link to post
Share on other sites
2 minutes ago, ProAvia said:

I think your template file is missing....

.../core/templates/SimBrief/SimBrief.php

Re-upload that file and see if it fixes your issue.

its still the same..

would the problem be if all my phpvms files are php and all of the simbrief files are tpl??

Link to post
Share on other sites
  • Administrators

So you are using phpVMS 5.5.2? I believe all your template files should be php then. And you may have to check all files in the modules for references to ".tpl" and change to ".php"

Link to post
Share on other sites
9 hours ago, ProAvia said:

So you are using phpVMS 5.5.2? I believe all your template files should be php then. And you may have to check all files in the modules for references to ".tpl" and change to ".php"

 

5 hours ago, shakamonkey88 said:

Also, you don’t access the features of this by going directly to index.php/simbrief. Read the instructions carefully. 

ive followed your instuctions but still when i click generate simbrief nothing happens

Link to post
Share on other sites
  • Members

Simbrief module for phpvms seems to not work so well with the crewcentre template as there are a lot of jquery conflicts 

as you can see from here 

simbrief.apiv1.js:116 Uncaught TypeError: Cannot read property 'value' of undefined
    at do_simbriefsubmit (simbrief.apiv1.js:116)
    at simbriefsubmit (simbrief.apiv1.js:86)
    at HTMLInputElement.onclick (2:677)

as this is a template issue i am not able to help you with this , you will need to find someone who is able to help you with jquery and templates

Link to post
Share on other sites
  • 3 weeks later...
  • 2 months later...

Hi guys!

I'm having a bit of an issue. All the files are in the correct places etc and I'm assuming we're receiving the information back but nothing seems to populate.

https://vcrew.infinityworldva.co.za/index.php/SimBrief?ofp_id=1531490648_016A5AAD82

That is what I get AFTER the Simbrief popup closes and forwards me to that page...It used to work perfectly fine but somewhere along the line while working on other things, this has gone array.

Link to post
Share on other sites
  • 4 weeks later...

Hi,

I installed the module and cannot get it to work. In the instructions it says: I cannot find line 195 or any corresponding link where to add this, see attached. I modified one line to take the user directly to Simbrief but is not supposed to work this way. Any help would be appreciated. 

4.Edit your schedule_briefing.tpl in /core/templates and in line 195 edit the link to corespond to your site
Example http://../index.php/SimBrief

when i call the module directly i get many errors like this:

Warning: simplexml_load_file(): http://www.simbrief.com/ofp/flightplans/xml/.xml:125: parser error : xmlParseEntityRef: no name in /home/noble6/public_html/iCrew.nobleairaus.com/core/modules/SimBrief/SimBrief.php on line 12

Warning: simplexml_load_file(): if (typeof(window.old_alert) != 'undefined' && typeof(jquery_confirm) != 'undef in /home/noble6/public_html/iCrew.nobleairaus.com/core/modules/SimBrief/SimBrief.php on line 12

Warning: simplexml_load_file(): ^ in /home/noble6/public_html/iCrew.nobleairaus.com/core/modules/SimBrief/SimBrief.php on line 12

 

 

schedule_briefing.zip

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...