Jump to content
StephParker

[SOLVED] Problem with installing phpvms

Recommended Posts

Hello,

I'm re-asking for help because after the first post nobody answer me.

I'm trying to get a VA online, I have ehost as hosting, uploading phpvms via cyberduck after creating a database, just following the manual instruction.

When i paste the install.php URL in my browser, error 500 shows up, i've tried to delete the .htaccess file but nothing has changed.

I've also contacted ghost support but they answer me they don't give support for third party.

Could someone please help me?

Share this post


Link to post
Share on other sites

Fatal error: Class 'DB' not found in /home2/bluechvi/public_html/core/common/SettingsData.class.php on line 28

Now that's what it's shows up

I think it's a database error, i've created one before

Share this post


Link to post
Share on other sites

Delete the DB and create a new one, delete all files and start from scratch, this time upload to your site root. Remember to use simpilot's version.

Share this post


Link to post
Share on other sites

Delete the DB and create a new one, delete all files and start from scratch, this time upload to your site root. Remember to use simpilot's version.

This seemed to fix a lot of my problems http://forum.phpvms.net/topic/20629-most-common-fixes-phpvms-installation/

But yes, remember to use simpilot's version - https://github.com/DavidJClark/phpvms_5.5.x

Thank you all. I will try tomorrow evening and let you know.

Good night!

Share this post


Link to post
Share on other sites

Hello, I've successfully opened the URL.

Right now i've another problem -_- i can't connect to database i've tried to follow the ehost support guide but it report access denied

Share this post


Link to post
Share on other sites

Hello, I've successfully opened the URL.

Right now i've another problem -_- i can't connect to database i've tried to follow the ehost support guide but it report access denied

I assume you did properly made you're database?

I'm a noob too but these problems tell me that there's something wrong in the configuration of your database.

The best way to avoid error's is to copy and paste the data from your hosting.

servername, database name, user name and password.

Further have I learned that the best way to install phpvms Is to use php 5.4 in your php settings.

I did use 5.5 either but had many problems with it.

And as suggested before use https://github.com/DavidJClark/phpvms_5.5.x

Share this post


Link to post
Share on other sites

I assume you did properly made you're database?

I'm a noob too but these problems tell me that there's something wrong in the configuration of your database.

The best way to avoid error's is to copy and paste the data from your hosting.

servername, database name, user name and password.

Further have I learned that the best way to install phpvms Is to use php 5.4 in your php settings.

I did use 5.5 either but had many problems with it.

And as suggested before use https://github.com/D...rk/phpvms_5.5.x

I've solved deleting the old and creating a new database

Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×