Jump to content
Sign in to follow this  
LH154

Failer with Template CrazyCreatives

Recommended Posts

Hi have worried me a template of crazy creatives.

After uploading I get the following error phpvms:

Notice: The template file "/home/stuttgar/public_html//lib/skins/crazyskin01/header.tpl" doesn't exist in /home/stuttgar/public_html/core/classes/TemplateSet.class.php on line 248

Can someone help me there?

Thank you

Share this post


Link to post
Share on other sites

Hi have worried me a template of crazy creatives.

After uploading I get the following error phpvms:

Notice: The template file "/home/stuttgar/public_html//lib/skins/crazyskin01/header.tpl" doesn't exist in /home/stuttgar/public_html/core/classes/TemplateSet.class.php on line 248

Can someone help me there?

Thank you

Hi LH154,

This could be because you are using PHP 5, change the extension from .tpl to .php and see if that works, if it does, do it for all files in the template.

Regards,

Myles.

  • Like 1

Share this post


Link to post
Share on other sites

What skin do you have? If you spent 75 bucks on the jet one, good luck. I own it and it took about 5 months of time to re-vamp it.

The sliders are a Joke, this is basically where "ALL" of your errors are coming from. Second, if your not familier with php, don't

bother, I highly recommend that you find someone who is and who OWNS dreamweaver, by Adobe. You won't re-vamp it without

the software. Crazyskins has a lot of issues with all but one of their skins. I've been dealing with it for sometime. As we have

4 phpvms sites running. However, if you can get it to work, the menu system alone is well worth the money. Have a look ! I

Just put one together for another site, not fully functional yet, but will be soon. The link is below for you. You Also need to

familiar with All PHP CGI scripting codes. It lives in your server, and if your using a Free hosting company or a cheap one

your out of luck . There are some serious changes to make to your server to get this to run. And be advised, anything for a

PHP version that is newer then 5.5, phpvms will do nothing but _____<-- fill in the blank. MySql or MySql Lite, both run

nicely on newer versions, so far I have not found any issues with any databases. Hope this helps you, and here is your

Link on how its suppose to look and run.

Jimbo

http://heritage-va.net/hva

Jim

Edited by Heritage1

Share this post


Link to post
Share on other sites

That error usually means that template isn't compatible with your phpvms version. What version of phpVMS are you using?

Share this post


Link to post
Share on other sites

Sorry, was away , thanks for responding.

Version 5.5.2

I've tried everything, and am looking if it even exsists, a newer version, as my hosting company is 100% up to date with all databases and php.ini CGI's.

Is there a newer version ??

Thanks ,

Jim

Share this post


Link to post
Share on other sites

PHP, thanks, I just figured everything out , oh my gosh, how stupid am I. (embarassing for sure). your right, its all about the function call and inserting the

public static call to all the common/*.class.php , files in the main class modules, I as mentioned before changed Hosting companies to a , high end for sure, but didn't realize of course the version of php is the latest. so the old php.ini I've been working with (5.3) is no longer. Entry of simple lines below I've posted works EVEN for

ALL of the "OLD" modules I own. Thank you so much for your help, its very very much appreciated for sure. Below is what I've done;

and again , thank you ! my site is up finally and yes, I would love to help those who need it, as mentioned in other posts, PHPVMS Forums here have been a life

safer for me, my site is up with CC Skin, (love it).

http://heritage-va.net/hva

One fixed script:::

class FleetData extends CodonData
{
 public static function GetAllAircrafts()
 // -- Function Name : GetAllAircrafts
 // -- Params :
 // -- Purpose :

 {
  $sql = 'SELECT * FROM '.TABLE_PREFIX.'aircraft WHERE `enabled` = 1';
  return DB::get_results($sql);
 }
 public static function getBasicInfo($id)
 // -- Function Name : getBasicInfo
 // -- Params : $id
 // -- Purpose :

 {
  //get basic info
  $sql = 'SELECT * FROM '.TABLE_PREFIX.'aircraft WHERE `enabled` = 1 AND id='.$id;
  $basicinfo = DB::get_row($sql);
  return $basicinfo;
 }
 public static function getDateOfPurchase($id)

REMEMBER , this works so far at 90% success rate on older modules, I've tested it in 3 sites. Don't forget the public "static" <--- function, it lives in this folder;

/core/common <---

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×