Jump to content
vbegin7

SmartCars "Pirep Filing Error" Fix

Recommended Posts

Dear phpvms & users,

I have just spoke with the TFDi team for multiple months on fixing a problem with my SmartCars for my Virtual Airline about pilots getting a "Pirep Filing Error" when Filing the pirep at the end of their flight i have sit for many hours trying to figure the problem out and have found a successful fix. Read below at what i have done to also maybe fix your "Pirep Filing Error" for your virtual airline.

The below code is found within the codon.config.php the first box below will be default and the following box will be with the changes.

session_start();[/b]
[b]error_reporting(E_ALL ^ E_NOTICE ^ E_WARNING);
@ini_set('display_errors', 'on');

i have changed display errors from on to off, This will not affect any error logs from within phpvms from what i have found but it is the clear fix to your problem. You can find this code on line 43 in the codon.config.php that is within your phpvmsinstallationfolder/core

session_start();[/b]
[b]error_reporting(E_ALL ^ E_NOTICE ^ E_WARNING);
@ini_set('display_errors', 'off');

I really hope this helps yourself and others that may be frustrated.

Best regards,

Vince @ WeFlyFSX.com

Share this post


Link to post
Share on other sites

Although this gets your issue with SmartCars fixed it only hides the root cause of the error, and now any others that may be occuring. You really should find what is causing the error to be produced in the first place.

Share this post


Link to post
Share on other sites

The error returned to a blank line in pilotdataclass got any suggestions on that blank line ?

If u was to sit there for months and not figure out what it could be and this fixed it what would you do ?

Share this post


Link to post
Share on other sites

Good day,

I'm am currently having the same issue where this error is occurring. We're using phpvms V5.

The error occurs, however, the PIREP has been files. The initial posts settings was already applied in the codon.config.php file.

When I check the smartCars log I see the following:

[09:28:19 PM] Windows 10, Build 17134, Suite Mask: 0x100, 64bit Architecture
[09:28:19 PM] Browser emulation mode set to 11001
[09:28:25 PM] Logged in to airline 861 as pilot 1 with dbid 1
[09:28:31 PM] set_color 4
[09:28:31 PM] set_color 7
[10:57:27 PM] The sim monitor thread returned
[10:57:32 PM] [ERROR] An unknown or unsatisfactoy response was received during the PIREP filing. It was :

Nothing else. No info on what the error is.

Any suggestions on what this issue could be?

Edited by loganq
Added information

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×