Jump to content
Nabeel

Just a tease

Recommended Posts

Guest lorathon

I am running Dave's 5.5.2 on a php7 server.  I do not remember any issues when installing or running it.  I do not have any addons just the vanilla install.

Share this post


Link to post
Share on other sites

I tried a new install on php7 and get an error

You need PHP 5 (your version: 7.0.2-pl0-gentoo)

Did you do anything to get it to install?

Share this post


Link to post
Share on other sites
Guest lorathon

I do not remember getting an error.  But I think that I installed and then upgraded to 7.  

Looking at the checkinstall.php file I found this.

if ($version[0] == '4' || $version == '5.0' || $version == '5.1') {
    error('Error!', 'Must be running at least PHP 5.2');
} else {
    $version = phpversion();
    success('OK', "PHP version is {$version}.x");
}

There maybe some more in the install files that are stopping the install.  Try removing this or setup on a php5 and then moving to php7

Share this post


Link to post
Share on other sites
On 12/4/2017 at 1:23 PM, lorathon said:

I do not remember getting an error.  But I think that I installed and then upgraded to 7.  

Looking at the checkinstall.php file I found this.


if ($version[0] == '4' || $version == '5.0' || $version == '5.1') {
    error('Error!', 'Must be running at least PHP 5.2');
} else {
    $version = phpversion();
    success('OK', "PHP version is {$version}.x");
}

There maybe some more in the install files that are stopping the install.  Try removing this or setup on a php5 and then moving to php7

In order to force an install on 7.0, editing checkinstall.php did nothing. Instead, you can just remove the following lines from install/includes/'Installer.class.php':

 

		if($version[0] != '5') {
			$noerror = false;
			$type = 'error';
			$message = 'You need PHP 5 (your version: '.$version.')';
		} else {
			$type = 'success';
			$message = 'OK! (your version:'.$version.')';
		}

Also, it will throw an error upon completion.. Just ignore it, it seemed to install fine.

Edited by atulumello

Share this post


Link to post
Share on other sites

I get this error when I click next step after filling out the form.

Uncaught Error: Call to undefined function mysql_connect() in /data/7/0/70/127/396779/user/403816/htdocs/phpvms/core/classes/ezdb/ezdb_mysql.class.php:98 Stack trace: #0 /data/7/0/70/127/396779/user/403816/htdocs/phpvms/core/classes/ezdb/ezdb.class.php(195): ezDB_mysql->connect('phpvms', 'my password', 'localhost') #1 /data/7/0/70/127/396779/user/403816/htdocs/phpvms/install/includes/Installer.class.php(139): DB::connect('phpvms', 'my password', 'phpvms', 'localhost') #2 /data/7/0/70/127/396779/user/403816/htdocs/phpvms/install/install.php(49): Installer::AddTables() #3 {main} thrown in /data/7/0/70/127/396779/user/403816/htdocs/phpvms/core/classes/ezdb/ezdb_mysql.class.php on line 98

 

Share this post


Link to post
Share on other sites
5 hours ago, flyalaska said:

I get this error when I click next step after filling out the form.


Uncaught Error: Call to undefined function mysql_connect() in /data/7/0/70/127/396779/user/403816/htdocs/phpvms/core/classes/ezdb/ezdb_mysql.class.php:98 Stack trace: #0 /data/7/0/70/127/396779/user/403816/htdocs/phpvms/core/classes/ezdb/ezdb.class.php(195): ezDB_mysql->connect('phpvms', 'my password', 'localhost') #1 /data/7/0/70/127/396779/user/403816/htdocs/phpvms/install/includes/Installer.class.php(139): DB::connect('phpvms', 'my password', 'phpvms', 'localhost') #2 /data/7/0/70/127/396779/user/403816/htdocs/phpvms/install/install.php(49): Installer::AddTables() #3 {main} thrown in /data/7/0/70/127/396779/user/403816/htdocs/phpvms/core/classes/ezdb/ezdb_mysql.class.php on line 98

 

I tried to recreate this on localhost using xampp.. The closest I got was when I had the wrong SQL type selected. It is my opinion that either you:

1. Are using mySQLi and attempted an install using mySQL, or vice versa.

2. Have created your database as the wrong type or your database user is set to % (any) rather than localhost.

3. Used the wrong credentials.

Share this post


Link to post
Share on other sites
14 hours ago, flyalaska said:

I get this error when I click next step after filling out the form.


Uncaught Error: Call to undefined function mysql_connect() in /data/7/0/70/127/396779/user/403816/htdocs/phpvms/core/classes/ezdb/ezdb_mysql.class.php:98 Stack trace: #0 /data/7/0/70/127/396779/user/403816/htdocs/phpvms/core/classes/ezdb/ezdb.class.php(195): ezDB_mysql->connect('phpvms', 'my password', 'localhost') #1 /data/7/0/70/127/396779/user/403816/htdocs/phpvms/install/includes/Installer.class.php(139): DB::connect('phpvms', 'my password', 'phpvms', 'localhost') #2 /data/7/0/70/127/396779/user/403816/htdocs/phpvms/install/install.php(49): Installer::AddTables() #3 {main} thrown in /data/7/0/70/127/396779/user/403816/htdocs/phpvms/core/classes/ezdb/ezdb_mysql.class.php on line 98

 

I think you need to set the database type as mysqli

Share this post


Link to post
Share on other sites

Tried both ways, mysql and mysqli

I get a different error with mysqli

Warning: mysqli::__construct(): (HY000/2002): No such file or directory in /data/7/0/70/127/396779/user/403816/htdocs/phpvms/core/classes/ezdb/ezdb_mysqli.class.php on line 101

Fatal error: Uncaught <blockquote><font face=arial size=2 color=000099><b>Last Error --</b> [<font color=000000><b>No such file or directory (2002)</b></font>]<br />[<font color=000000><b></b></font>]</font><p> </blockquote><hr noshade color=dddddd size=1> thrown in /data/7/0/70/127/396779/user/403816/htdocs/phpvms/core/classes/ezdb/ezdb_mysqli.class.php on line 106

Line 106 is

throw new ezDB_Error(mysqli_connect_error(), mysqli_connect_errno());

 

Edited by flyalaska

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×