Jump to content

Possible problem with MariaDB?


Imanol
 Share

Recommended Posts

Hi everyone,

Since last week my virtual airline can not receive flights reports because the PIREPS function stopped working by surprise (manually or through smartCARS).

I tried reinstalling the PIREPS module, the classes files and the whole site using the last version of phpVMS available but it does not work either.

I contacted my hosting provider and after some tests they told me it could be a problem compatibility with MariaDB. Last Wednesday they updated their servers, including MariaDB, since then I have this issue.

 

Here you have more details:

SQL: 10.2.8-MariaDB
phpMyAdmin: 4.7
Apache: 2.4.27 + LSAPI
PHP 7.0.22

Could be this a problem with MariaDB?

Edited by Imanol
Link to comment
Share on other sites

  • 6 months later...
  • 1 year later...
On 3/29/2018 at 8:10 PM, Cor said:

Solution back to MariaDB 10.1 :lol:

Dear all

It looks like this has hit our airline now. It all started after pilots were not able to file PIREPs with error "There was an error adding your PIREP : Schedule does not exist. Please update this manually.". As the error made no sence, I googeled for hrs., tried different steps, but nothing has worked so far. I have been contact with our hosting company and they sayd that they performed an update from MariaDB 10.1.38 to 10.3.14. rollback not possible. So it looks like it might be related. I am running phpvms 5.5.x @ http://efb.flying.ee/ with highly customized systems, not really ready to move to phpvms 7 yet. Rest of the site works perfectly, sending PIREPs is impossible.

Is there anyone who can advise what to do further besides rollback or get another hosting company? There has to be a solution from our side as I can imagine that this problem will spread as MariaDB 10.3 is out since 2017?

Waiting for a soonest reply.

Link to comment
Share on other sites

  • Administrators
16 hours ago, yourairways said:

Dear all

It looks like this has hit our airline now. It all started after pilots were not able to file PIREPs with error "There was an error adding your PIREP : Schedule does not exist. Please update this manually.". As the error made no sence, I googeled for hrs., tried different steps, but nothing has worked so far. I have been contact with our hosting company and they sayd that they performed an update from MariaDB 10.1.38 to 10.3.14. rollback not possible. So it looks like it might be related. I am running phpvms 5.5.x @ http://efb.flying.ee/ with highly customized systems, not really ready to move to phpvms 7 yet. Rest of the site works perfectly, sending PIREPs is impossible.

Is there anyone who can advise what to do further besides rollback or get another hosting company? There has to be a solution from our side as I can imagine that this problem will spread as MariaDB 10.3 is out since 2017?

Waiting for a soonest reply.

Is there an error log or possible to get the error from SQL? I was gonna ask what the sql error, etc, might be above this line:

https://github.com/nabeelio/phpvms_v2/blob/88656de961463b46ce742c77455c67c5c06fdfac/core/modules/PIREPS/PIREPS.php#L127

 

Link to comment
Share on other sites

  • 2 weeks later...
  • Administrators

phpVMS 5.5.2 won't install correctly using  MySQL 5.7

While there are some incompatibilities and feature differences between Maria DB and MySQL........

  • Maria DB 10.2 is compatible with MySQL 5.7
  • Maria DB 10.0 is compatible with MySQL 5.6

https://mariadb.com/kb/en/library/mariadb-vs-mysql-compatibility/

Edited by ProAvia
Link to comment
Share on other sites

  • Administrators
16 hours ago, yourairways said:

Hi, could you please advise where to get/access the SQL error log? Did not find anything related from cPanel. There was nothing specific on error_log created by phpVMS itself.

 

Unfortunately, you'll have to edit the code where I pointed out so that you can output the exact message there. Unfortunately, it could just be that the code is just too "old" to support maria properly. As @ProAvia pointed out, though they're supposed to be compatible, there could still be issues in compat

Link to comment
Share on other sites

  • 3 months later...
  • Administrators
1 hour ago, JohanVFRclubNL said:

It seems we got this problem too. Any progress on how to solve this?

We can't go back to an early version of MariaDB

Fresh install. phpVMS 5.5.27, php7.2

 

Did you mean version 5.5.2.72 ?

What version of php... 7.2.??

What version of Maria DB?

Do you have the option of using MySQL instead of Maria DB?

 

Edited by ProAvia
Link to comment
Share on other sites

9 hours ago, ProAvia said:

Did you mean version 5.5.2.72 ?

What version of php... 7.2.??

What version of Maria DB?

Do you have the option of using MySQL instead of Maria DB?

phpVMS: Version ##REVISION## 5.5.2.72 (phpVMS 5.5.2 for PHP 7.2)

php version: 7.2.21

MariaDB-1:10.3.14

I have no option for MySQL

Link to comment
Share on other sites

  • Administrators

phpVMS 5.5.2.72 was tested with MySQL 5.6 and 5.7 - it was not tested with any versions of MariaDB.

Are you able to change the version of MariaDB to 10.1 or 10.2?

Can you downgrade you PHP version to 5.6? If so, install phpVMS 5.5.2 (Simpilot version).

Who is you web hosting company?

Here are a couple of links that may or may not help....

https://mariadb.com/kb/en/library/incompatibilities-and-feature-differences-between-mariadb-103-and-mysql-57/

https://mariadb.com/kb/en/library/mariadb-vs-mysql-compatibility/

EDIT - can you post any error_log files? Have you opened your browser console to see if any errors are posted there?

Edited by ProAvia
Error logs request
Link to comment
Share on other sites

  • 1 year later...
  • 2 weeks later...

This is due to strict mode being implemented, I had found a work around by putting INSERT IGNORE for all insert requests. Basically it comes down to the way phpvms stores the date and time of a pirep being filed. Using the INSERT IGNORE will allow the data to be submitted to the db as it ignores any error that is thrown up. It is not the best but for what i can see the only way to work around this problem if you do not have a VPS or dedicated server. As most hosts are reluctant to turn strict mode off.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...