Jump to content
asandor

Feature Request for v7

Recommended Posts

Would it be possible to add Departure and Arrival gates to the Flights and have them show when you place a bid on the flight.

Share this post


Link to post
Share on other sites

You can use the flight fields for this. I just added a function to the flight to make it easier to display in a template.

In the admin, go to the flight, under Custom Fields, you can add "Departure Flight", and a value.

Then in the template, you can put:

{{ $flight->field('Departure Gate') }}

It's kind of a pain with a lot of flights, but the importer will have a way to be able to add the fields and values right in the CSV (https://github.com/nabeelio/phpvms/issues/194)

I might add another table, like with PIREPs, that holds a "master" list of the flight fields and then it'll show them on the create/edit page as a main list, so you don't have to type "Departure Gate" over and over.

Share this post


Link to post
Share on other sites

Remove my phpvms directory, reinstalled from scratch, I get the following error when I try to add a subfleet.

[2018-03-20 19:43:43] dev.ERROR: Cannot access protected property App\Models\Subfleet::$rules {"userId":1,"email":"asandor@ke6ihx.com","exception":"[object] (Symfony\\Component\\Debug\\Exception\\FatalThrowableError(code: 0): Cannot access protected property App\\Models\\Subfleet::$rules at /var/www/phpvms/app/Http/Requests/CreateSubfleetRequest.php:27)

Entire log file attached also

laravallog.zip

Share this post


Link to post
Share on other sites
1 hour ago, Michael2015 said:

Can you do this in phpvms 5

Nope

Share this post


Link to post
Share on other sites
4 hours ago, asandor said:

Remove my phpvms directory, reinstalled from scratch, I get the following error when I try to add a subfleet.

[2018-03-20 19:43:43] dev.ERROR: Cannot access protected property App\Models\Subfleet::$rules {"userId":1,"email":"asandor@ke6ihx.com","exception":"[object] (Symfony\\Component\\Debug\\Exception\\FatalThrowableError(code: 0): Cannot access protected property App\\Models\\Subfleet::$rules at /var/www/phpvms/app/Http/Requests/CreateSubfleetRequest.php:27)

Entire log file attached also

laravallog.zip

Thanks, just fixed.

Share this post


Link to post
Share on other sites

Getting a different error this time, same place though, hitting save when trying to enter a subfleet.

[2018-03-21 01:16:19] dev.ERROR: Validation rule unique requires at least 1 parameters. {"userId":1,"email":"asandor@ke6ihx.com","exception":"[object] (InvalidArgumentException(code: 0): Validation rule unique requires at least 1 parameters. at /var/www/phpvms/vendor/laravel/framework/src/Illuminate/Validation/Concerns/ValidatesAttributes.php:1539)

 

laravel-2018-03-21.zip

Share this post


Link to post
Share on other sites
13 hours ago, asandor said:

Getting a different error this time, same place though, hitting save when trying to enter a subfleet.

[2018-03-21 01:16:19] dev.ERROR: Validation rule unique requires at least 1 parameters. {"userId":1,"email":"asandor@ke6ihx.com","exception":"[object] (InvalidArgumentException(code: 0): Validation rule unique requires at least 1 parameters. at /var/www/phpvms/vendor/laravel/framework/src/Illuminate/Validation/Concerns/ValidatesAttributes.php:1539)

 

laravel-2018-03-21.zip

D'oh! Fixed

Share this post


Link to post
Share on other sites

So, I have an issue and I'm not sure if its the phpvms code or the code for the acars app Vangelis put up for v7

A little backstory with it, when the a week or so ago I tried the app and added 2 B738s and 2 A320s to the fleet. When I when into the acars app under the subfleets the 737-800 and the A320-214 showed up, but when I selected one, under the aircraft drop down only the word (Collection) showed up and it gave an error when I tried to start the flight. That is the error that I posted on the forum in the AVAcars thread.

Yesterday all was working good, and since I didn't do anything different and vangelis never posted anything about the error, I though something you did fixed it. Well after the updates today, the issue is back and aircraft only show (Collection) now.

In the acars app when I select the flight that I have booked I also get a 'Cannot bind to new display member. Parameter name: newDisplayMember'

Again, this worked yesterday.

Also, nothing is showing up in the laraval log when those issues occur.

Edited by asandor

Share this post


Link to post
Share on other sites

Hmm. Collection is a Laravel, but also a C# type, so it could mean that the API is returning something incorrect. It's when you've selected a subfleet to get the list of aircraft? Nothing's changed on the API side, though, well nothing directly.

Can you PM me your site URL and the API key of the user you're using? Let me see if there's something weird coming out of the API

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×