Jump to content
ARV187

I can't bill unbill flights

Recommended Posts

Hi, I updated phpvms7 from github, but now I can't bill/unbill flights, server log say:

Quote

client denied by server configuration: /home/argavirt/public_html/phpvms7/api, referer: http://argavirtual.com/phpvms7/flights

What chmod permission type I need and that files?

My .htaccess:

 

# Use php7.2
AddHandler application/x-httpd-php72 .php

# Disable index view
Options -Indexes

RewriteEngine On

# Handle Authorization Header
RewriteCond %{HTTP:Authorization} ^(.*)
RewriteRule .* - [e=HTTP_AUTHORIZATION:%1]

# Deny all these files/folders
RedirectMatch 403 ^/.git/.*?$
RedirectMatch 403 ^/.travis/.*?$
RedirectMatch 403 ^/app/.*?$
RedirectMatch 403 ^/bootstrap/.*?$
RedirectMatch 403 ^/config/.*?$
RedirectMatch 403 ^/modules/.*?$
RedirectMatch 403 ^/node_modules/.*?$
RedirectMatch 403 ^/resources/.*?$
RedirectMatch 403 ^/storage/.*?$
RedirectMatch 403 ^/tests/.*?$
RedirectMatch 403 ^/vendor/.*?$
RedirectMatch 403 ^/.bowerrc$
RedirectMatch 403 ^/artisan$
RedirectMatch 403 ^/composer.json
RedirectMatch 403 ^/composer.lock
RedirectMatch 403 ^/composer.phar
RedirectMatch 403 ^/env.php.*?$
RedirectMatch 403 ^/env.php
RedirectMatch 403 ^/env.php$
RedirectMatch 403 ^/Makefile
RedirectMatch 403 ^/package.json
RedirectMatch 403 ^/package-lock.json
RedirectMatch 403 ^/phpunit.xml
RedirectMatch 403 ^/webpack.mix.js

# Redirect Trailing Slashes If Not A Folder...
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)/$ /$1 [L,R=301]

# Handle Front Controller...
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^ index.php [L]

 

Edited by ARV187

Share this post


Link to post
Share on other sites

I think that others web page options work, Do I try something specific?

 

P.S: My phpvms7 is in public_html/phpvms7/ directory, I say this because seems that it's trying find assets in home directory:

client denied by server configuration: /home/argavirt/public_html/phpvms7/api, referer: http://argavirtual.com/phpvms7/flights
client denied by server configuration: /home/argavirt/public_html/phpvms7/api, referer: http://argavirtual.com/phpvms7/flights
File does not exist: /home/argavirt/public_html/api, referer: http://argavirtual.com/phpvms7/livemap
File does not exist: /home/argavirt/public_html/assets
File does not exist: /home/argavirt/public_html/assets

 

May be this directory? /public_html/phpvms7/public/assets

Edited by ARV187

Share this post


Link to post
Share on other sites
2 hours ago, Nabeel said:

Are any API calls working?

How I check that?

In past versions are working, I'm thinking in reinstall again to see if that fix the issue, I need reset the database too or I can restore it?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×