Jump to content

[SKIN] [Free] StislaSkin 2020 - Designed for phpVMS 5.5.2.72 (ProAvia) - v1.0 [w/ Leaflet & Book by map]


CarlosEduardo2409
 Share

Did you like StislaSkin?  

56 members have voted

  1. 1. Did you like StislaSkin?

    • Yes!
      54
    • No! (Please tell me what I can improve)
      2


Recommended Posts

6 hours ago, RafaelLeite said:

That's what I meant. If was possible. Maybe I expressed myself in a wrong way. I want to know if is possible....and if yes, which file shoudl I edit...

Hi! Sorry for the delay.

 

If you want to change the colors of buttons, cards, among others, it really is to be in the skin's style.css file, which is located in lib/skins/StislaSkin/assets/style.cssfor example: located at line 79 - This will change the color of that "card": https://prnt.sc/sl0mau

.bg-primary { background-color: #23ad96 !important; }

 

The same thing for buttons, for example (located at line 1305):

.btn-primary, .btn-primary.disabled {
    box-shadow: 0 2px 6px #acb5f6; /* And to be more beautiful, but with a different color from the background-color, and without being too different */
    background-color: #23ad96; /* This is the mainly */
    border-color: #6777ef; /* And to be more beautiful, but with a different color from the background-color, and without being too different */
}

 

You can also change the button itself (or div tag, span tag, anything else...), but it will only change that button, for example:

<button class="btn btn-primary btn-round" style="background-color: #000 !important;">Some button</button>

 

  • Like 1
Link to comment
Share on other sites

Carlos

 

please help....

 

I did a new, fresh install as recommended and now I'm getting this errors at the top... ( I did not have it before):

 

 

 

 

Warning: Wrapper is disabled in the server configuration by allow_url_fopen=0 in /home/virtualv/public_html/vms/lib/skins/StislaSkin/app_top.php on line 20

Warning: file_get_contents(http://www.virtualvarigbrasil.org/vms/lib/skins/StislaSkin/config.json): failed to open stream: no suitable wrapper could be found in /home/virtualv/public_html/vms/lib/skins/StislaSkin/app_top.php on line 20

 

Warning: file_get_contents(): http:// wrapper is disabled in the server configuration by allow_url_fopen=0 in /home/virtualv/public_html/vms/lib/skins/StislaSkin/frontpage_main.php on line 13

 

Warning: file_get_contents(http://www.virtualvarigbrasil.org/vms/lib/skins/StislaSkin/config.json): failed to open stream: no suitable wrapper could be found in /home/virtualv/public_html/vms/lib/skins/StislaSkin/frontpage_main.php on line 13

 

 

Link to comment
Share on other sites

  • Administrators
47 minutes ago, RafaelLeite said:

Carlos

 

please help....

 

I did a new, fresh install as recommended and now I'm getting this errors at the top... ( I did not have it before):

 

 

 

 

Warning: Wrapper is disabled in the server configuration by allow_url_fopen=0 in /home/virtualv/public_html/vms/lib/skins/StislaSkin/app_top.php on line 20

Warning: file_get_contents(http://www.virtualvarigbrasil.org/vms/lib/skins/StislaSkin/config.json): failed to open stream: no suitable wrapper could be found in /home/virtualv/public_html/vms/lib/skins/StislaSkin/app_top.php on line 20

 

Warning: file_get_contents(): http:// wrapper is disabled in the server configuration by allow_url_fopen=0 in /home/virtualv/public_html/vms/lib/skins/StislaSkin/frontpage_main.php on line 13

 

Warning: file_get_contents(http://www.virtualvarigbrasil.org/vms/lib/skins/StislaSkin/config.json): failed to open stream: no suitable wrapper could be found in /home/virtualv/public_html/vms/lib/skins/StislaSkin/frontpage_main.php on line 13

 

 

 

Your error has absolutely nothing to do with this skin. See your other thread for a possible solution. You were also advised not to install any skins or modules until after your new install was working correctly with the default skin - which it isn't.

Link to comment
Share on other sites

Carlos, first off thank you for the skin. The functions are super. My question is about cosmetics. I read the post above about modifying the css, but I can't seem to find the line to change the color of the top bar. (See Picture)gFHIPVJ.jpg

I would like to make to make this bar black (#00000) as well as to add my VA's logo to the right of the 3 line sidebar link. I apologize if this is a rookie question, but I'm a rookie with PHP.

Link to comment
Share on other sites

Good morning everyone and as always congratulations for your work
I installed ProAvia phpVMS 5.5.2.72 (phpVMS 5.5.2 updated for PHP 7.2)
and this skin, and all the addons, the only thing I'm missing is the symbrief API key, I'm waiting for you to send it to me.
I followed all the instructions step by step, with only phpVMS I have no problems I can do all the operations.
But when I install the skin I can't add the planes, every time I get this error "There was an error adding the aircraft"

I tried to insert it from Mysql and it works perfectly
can you help me understand how to identify the problem?

Thanks a lot in advance, and again congratulations for the work done

Link to comment
Share on other sites

(SOLVED ) Good morning, I have successfully installed the skin but I have 1 error that I do not know how to solve, one is related to the live flight position (the correct position is not shown) attached image. itI really appreciate your help.      

 

IMG_20200624_160659.jpg

Do I have to do this link modification?

Or should I see the position of the plane and the correct route instead of a straight line?

I really appreciate your help, I also found another error in EVENTS, it does not allow adding a new event

 

Help me please 

Help me please

Edited by Lebitek
Link to comment
Share on other sites

Hello again,

A while ago I asked about the sim brief button and I tried all the responses with no success.

Refused to execute script from 'http://vwestjet.org/phpvms/index.php/schedules/brief/www.vwestjet.org/phpvms/core/modules/SimBrief/simbrief.apiv1.php?api_req=CYYCCYVRB7361593199709vwestjet.org/phpvms/index.php/SimBrief&p=1542428' because its MIME type ('text/html') is not executable, and strict MIME type checking is enabled.

That's the error that pops up in the console. Any help on this would be great as we're trying to finish this thing up.

Link to comment
Share on other sites

  • Administrators

A quick Google search of --- refused to execute script from because its MIME type ('text/html') is not executable, and strict MIME type checking is enabled --- from your error message will yield a number of possible solutions.

 

Here's one possible clue to a solution: https://stackoverflow.com/questions/40574159/refused-to-execute-script-strict-mime-type-checking-is-enabled

Link to comment
Share on other sites

2 hours ago, ProAvia said:

A quick Google search of --- refused to execute script from because its MIME type ('text/html') is not executable, and strict MIME type checking is enabled --- from your error message will yield a number of possible solutions.

 

Here's one possible clue to a solution: https://stackoverflow.com/questions/40574159/refused-to-execute-script-strict-mime-type-checking-is-enabled

Like I said, I have tried all the responses people gave me last time. You gave me this article last time and it wasn't the problem.

Link to comment
Share on other sites

  • Administrators
5 hours ago, EvanAnderson said:

Like I said, I have tried all the responses people gave me last time. You gave me this article last time and it wasn't the problem.

 

Did you search Google any further then the link I provided?

Is there a way to change the strict MIME type checking from enabled to disabled?

Link to comment
Share on other sites

18 hours ago, EvanAnderson said:

Like I said, I have tried all the responses people gave me last time. You gave me this article last time and it wasn't the problem.

Hello captain, if it refers to the button to generate OFP of Simbrief I found the solution, you must first have the path of your correct web page in app.config.php including www example.com

Link to comment
Share on other sites

19 hours ago, EvanAnderson said:

Like I said, I have tried all the responses people gave me last time. You gave me this article last time and it wasn't the problem.

Go to this file (main folder / CORE / local.config.php) and verify that your url is correct. look at the image of mine.

ex-1.png

then check that this is the correct format in the following file (main folder / LIB / SIKNS / STISLASKIN / schedule_briefing.php) look at the format equal to mine with your correct url

ex-2.png

I hope I have helped .

Link to comment
Share on other sites

2 hours ago, Lebitek said:

Go to this file (main folder / CORE / local.config.php) and verify that your url is correct. look at the image of mine.

ex-1.png

then check that this is the correct format in the following file (main folder / LIB / SIKNS / STISLASKIN / schedule_briefing.php) look at the format equal to mine with your correct url

ex-2.png

I hope I have helped .

Hmmmm, yes botth of those are correct, I do have all the phpVMS files in a folder (vwestjet.org/phpvms/). I directed the site URL thing in local.config.php but I don't think that will make a difference. If I'm wrong let me know but so far nothing has worked...

Link to comment
Share on other sites

9 hours ago, EvanAnderson said:

Hmmmm, yes botth of those are correct, I do have all the phpVMS files in a folder (vwestjet.org/phpvms/). I directed the site URL thing in local.config.php but I don't think that will make a difference. If I'm wrong let me know but so far nothing has worked...

I guarantee that I had the same error, pressing the OFP button for simbrief did not get a response, that is because in (main folder / LIB / SIKNS / STISLASKIN / schedule_briefing.php) in that file this rl button is pointing to SITE_URL and in the file (main folder / CORE / local.config.php) you are indicating the URL assigned to SITE_URL. Remember to fill it in ((http or https://www.example.com)).

Also remember to assign the permissions to .htcacces in your main installation folder, the permissions have to be 755, also to your phpvms folder (in my installation I don't have the (phpvms) folder and it works fine, my version is phpvms 5.5.7.2 and i am using php 7.1.

excuse my spelling, I use a translator

Edited by Lebitek
Link to comment
Share on other sites

On 6/28/2020 at 1:03 AM, Lebitek said:

I guarantee that I had the same error, pressing the OFP button for simbrief did not get a response, that is because in (main folder / LIB / SIKNS / STISLASKIN / schedule_briefing.php) in that file this rl button is pointing to SITE_URL and in the file (main folder / CORE / local.config.php) you are indicating the URL assigned to SITE_URL. Remember to fill it in ((http or https://www.example.com)).

Also remember to assign the permissions to .htcacces in your main installation folder, the permissions have to be 755, also to your phpvms folder (in my installation I don't have the (phpvms) folder and it works fine, my version is phpvms 5.5.7.2 and i am using php 7.1.

excuse my spelling, I use a translator

unknown.pngunknown.pngunknown.pngunknown.pngunknown.png

 

I've tried everything you've said yet I still get this error in the console whenever I press the button... Is there something I've missed?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...