Problem!

Hello folks,

I had some problems during the installation process. I’m able to acess the index page, but when I try to do anythin in this page (like acess the pilots, or live map) a message like this appears:

Warning: include(core/codon.config.php): failed to open stream: Operation not permitted in /www/zxq.net/e/i/c/eicosairlinesvirtual/htdocs/index.php on line 40 Warning: include(): Failed opening ‘core/codon.config.php’ for inclusion (include_path=‘.:/usr/lib/php’) in /www/zxq.net/e/i/c/eicosairlinesvirtual/htdocs/index.php on line 40 Fatal error: Class ‘Config’ not found in /www/zxq.net/e/i/c/eicosairlinesvirtual/htdocs/index.php on line 42

What I have to do?

Hello. I see you are on free hosting. I am not sure what this error is, but most of the time, phpVMS will NOT run very well on free hosting. Search this forum for that particular error and see what you can come up with. I will check between now and then myself.

You could also try re-uploading your codon.config.php file and see if it works. (I never request or support free hosting)

I’m still having this problem. I’m sure that it isn’t caused by the free host.

Change permissions on the file to 777

Change permissions on the file to 777

Nabeel you beat me to it. I was just coming back here to give that same advice. I don’t know why I did not think of it to begin with.

Still having problems.

Oh it’s when accessing a page, that means the server is setup incorrectly

Oh it’s when accessing a page, that means the server is setup incorrectly

What I have to do to correct this?

You need to contact your host, they will have to adjust the config of the server, unless you are on a dedicated or vps with root access you could make the changes yourself. Looking at it quick I would say some of the fastcgi settings are incorrect.

You need to contact your host, they will have to adjust the config of the server, unless you are on a dedicated or vps with root access you could make the changes yourself. Looking at it quick I would say some of the fastcgi settings are incorrect.

I have the root acess, tell me what to do.

Paste the output from running install/checkinstall.php

Here is:

phpVMS Virtual Airline Administration Software

Install Check

get(PHPVMS_API_SERVER.‘/version’); if($contents == ‘’) { $error = $file->errors[count($file->errors)-1]; error(‘Connection failed’, ‘Could not connect to remote server - error is "’.$error.‘"’); } else { success(‘OK’, ‘Can contact outside servers’); } unset($file); /* Simple XML? */ echo ’

'; echo 'Checking for SimpleXML module…

'; if(function_exists(‘simplexml_load_string’) == true) { success(‘OK’, ‘SimpleXML module exists!’); } else { error(‘Fail’, ‘SimpleXML module doesn't exist or is not installed. Contact your host’); } /* File hashes check */ echo ’

'; echo 'Checking file hashes for corrupt or mismatched files

‘; $fp = fopen(HASH_LIST, ‘r’); if(!$fp) { error(‘Fatal’, ‘Could not read ‘.HASH_LIST); exit; } $total = 0; $errors = 0; while(!feof($fp)) { $line = fgets($fp); $line = trim($line); if(empty($line)) continue; fscanf($fp, ‘%s %s’, $checksum, $file); $total ++; $file = str_replace(’*./’, ‘../’, $file); if($file == ‘../core/local.config.php’ || substr_count($file, ‘unittest’) > 0 || empty($file)) { continue; } if(!file_exists($file)) { $errors++; error(‘Error’, “{$file} doesn’t exist”); continue; } $calc_sum = md5_file($file); $file = str_replace(’../', ‘/’, $file); # make pretty if($calc_sum === false) { $errors++; error(‘Checksum failed’, “{$file} - permissions might be incorrect!”); continue; } if($calc_sum != $checksum) { $errors++; error(‘Checksum failed’, “{$file} did not match, possibly corrupt or out of date”); continue; } $file = ‘’; } if($errors == 0) { success(‘OK’, ‘No errors found!’); } echo "

– Checked {$total} files, found {$errors} errors

"; ?>

Is that what you get when you go to that page? Dont copy the code from that page just go to

yoursiteurl/install/checkinstall.php

Something is really messed up on your server/PHP isn’t installed correctly