Jump to content

Vetrro

Members
  • Posts

    7
  • Joined

  • Last visited

  • Days Won

    1

Posts posted by Vetrro

  1. Renaming to CI did not work, and no problem on taking awhile to reply its not really that big of a deal since most of our VA uses ACARS but I would like to have no errors on the site and this is the only one we have atm :P 

  2. We have a custom field in the pirep area and if I remove the field pireps file fine again but I would like to keep the field if I could. I tried re-adding the field after deleting it and it still has the issue.  So by the error saying it cant find the custom field is that meaning It cant find it on the pirep creation page? Or does it mean that it cant find some other way. Sorry if I'm frustrating to answer but I'm not too good with code stuff as of yet lol

    As for the custom field it is showing up on the pirep creation page as a field and can be filled out. I've included images of what I mean not sure if it is any help at all though shows the field that is created in the admin panel and then the field showing up on the pirep creation page.

    Thanks for the reply at least I understand what's causing the issue now I just still don't know how to get a fix in.

    d406199787f449479ffb946eb4a01bfc.png

    ff0f3b547d6055323ea9fda425a7060f.png

  3. PHP Version: 7.4.21
    phpVMS Version: 7.0.0-dev+210620.cde6fb
    MariaDB Version: 10.3.29

     

    Whenever a pirep is submitted it throws out this error:   "Trying to get property 'name' of non-object {"userId":1,"exception":"[object] (ErrorException(code: 0): Trying to get property 'name' of non-object at /phpvms/app/Services/PirepService.php:577)"

    and I'm not to sure how to go about fixing it so any help would be great :) Thanks.

    also included an image of where the error is occurring if that helps 

    f13b985e21191a2c337e507e2e00f12b.png

     

    Edit:

    Also some further information regarding this, When the pirep is summited it still goes through to the admin panel for viewing/approving but when the actual submission is done it brings up a 500 server error page for the user submitting it. 

  4. Captcha v2 on highest security setting (Selecting pictures tests)

    phpVMS Version: 7.0.0-beta.4 (Not actually sure if this is the latest but this is the latest version I see on github)

    PHP Version: 7.3

    MariaDB: 10.3.29

    As for blocking IP ranges where would that be done that would be something I have not done before so not sure where to look for that. If I am able to block IP addresses though that would probably solve the issue as all of those users are from the same IP

     

  5. Hello, 

    If anyone may be able to help with this issue then that would be greatly appreciated. So as for the issue we have Recaptcha working but some bots/spam users keep registering with the same email types from russia.

    Emails that keep signing up: 
    @dizaer.ru

    @yandex.com

    Ive also attached an image showing that our recaptcha is indeed working, but all the green passes in the image are the spambots. So these bots are either able to get through the tests or they are not actually bots and its people just spamming the site. Is there any way to block specific emails from signing up to mitigate the problem.

    Also added in an image of some of the accounts in question from our site.

    Again any help would be great and if anyone needs more information let me know :)

    recaptcha chart.png

    2dee4605d47d98babe97e4db64ae4e1a.png

×
×
  • Create New...