Jump to content

Installing phpVMS 5.x: Fatal Error!


Recommended Posts

Hello!

When I try to install phpVMS 5 I keep gettin this error:

Quote

Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 1667182680 bytes) in /public_html/crewcenter/core/classes/ezdb/ezdb_mysqli.class.php on line 274

Can some one help me with this?

Thanks alot!

Link to post
Share on other sites
3 hours ago, flyalaska said:

you don't have enough memory.

Hmmm, that seems logic to me haha. But I got a paid webhosting, so that sounds weird.. what kind of memory do I need to expand? Bandwith? Mysql?

 

bandwith.png

Edited by Yessin
Added some pictures
Link to post
Share on other sites
43 minutes ago, PaintSplasher said:

It is not the disk space, it is the memory_limit what php can use.

1. Create a file with the follow content:


<?php
phpinfo();
?>

2. Save this file on your webspace an open it in your browser

3. Search for "memory_limit".

I am going to check this in a few minutes! :)

EDIT:

128m.png

And I found a way to upgrade the memory limit to 512M but it still keeps saying it isn't anough <_<

Edited by Yessin
Added picture
Link to post
Share on other sites
10 minutes ago, PaintSplasher said:

256M should be enough. Have you reboot your apache after you have changed the limit?

And check the file again, to make sure the new memory limit is active.

Hmm ok! I have it set on 256M now, checked it on the file and is says: "memory_limit: 256" but the error is stil active. So weird..

Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 1936942488 bytes) in /public_html/crewcenter/core/classes/ezdb/ezdb_mysqli.class.php on line 274

 

Link to post
Share on other sites
2 minutes ago, PaintSplasher said:

Hm,

there must be an other issue, no script or class needs one gigabyte of memory. And you try to do a clean install of phpvms 5.5? (https://github.com/DavidJClark/phpvms_5.5.x)

Not yet, I already installed phpvms and the installation was smoothly. But after it finished, this showed up. Maybe if I try to do a clean install now, with the new setting to 256M? I will let you guys know if that works.

Link to post
Share on other sites
2 hours ago, anushpatel said:

I am not surprised for 0.50 Euros! 

Hahaha. I had to change the php version back from 7.1 to 5.6, chmod the folder 'lib' and 'core' to 777 and do a clean install. Its works now. Now the edit can begin! Thanks alot!

Edited by Yessin
  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...