Jump to content
Nabeel

Site errors

Recommended Posts

Some sites are not working because of doing on PHP 5.4+. There are some changes that need to be made, luckily pretty simple. If you haven't modified anything, look at: https://github.com/nabeelio/phpvms_v2. The php70 branch (default, download here: https://github.com/nabeelio/phpvms_v2/archive/php70.zip) is updated to support PHP 7+

If you're on the 5.x version, you should be fine.

action.php

Find ~Line 46:

error_reporting(E_ALL ^ E_NOTICE);

Change to:

error_reporting(E_ALL ^ E_NOTICE ^ E_STRICT);

 

core/local.config.php

Find (~L139):

Config::Set('ERROR_LEVEL', E_ALL ^ E_NOTICE);

Change to:

Config::Set('ERROR_LEVEL', E_ALL ^ E_NOTICE ^ E_STRICT);

admin/action.php

Find:

error_reporting(E_ALL ^ E_NOTICE);

Change to:

error_reporting(E_ALL ^ E_NOTICE ^ E_STRICT);

core/common/PilotData.class.php

Find (~line 436)

public static function saveAvatar($code, $pilotid, $_FILES)

Change to:

public static function saveAvatar($code, $pilotid, $files)

 

core/classes/CodonModule.class.php

Find:

public static $post;
public static $get;

Change to:
    

public $post;
public $get; 

core/classes/Vars.class.php

Find:

self::$get =  new stdClass();

Add under it:  

self::$request = new stdClass();

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×