Jump to content

Hours Not Updating - when PIREP Accepted


DesComm
 Share

Recommended Posts

  • 2 weeks later...
  • 1 month later...
  • 1 year later...
  • Administrators

@Skytraveler

For clarification:

  • PIREP hours don't update when you approve the PIREP?
  • PIREP hours do update after running the maintenance script?
  • Is this something new, or has it been doing it for a while?
  • If new, what were the last modules your added or files you edited since it was working correctly?

You already stated you are on phpVMS 5.5.2

  • Was this a conversion from phpVMS 2.1.x or a totally new install at some point?
  • What PHP version?
  • What MySQL/MariaDB version?

 

Link to comment
Share on other sites

Hi. Thanks for your reply.

 

- PIREP hours don't update after PIREP approval;

- They do update after running maintenance script;

- It's not new, I don't know what triggered it. I just have time now to try to address this;

- This was a conversion from phpVMS 2.1.x;

- The PHP version is 5.3

- mySQL 5.6.43

Link to comment
Share on other sites

  • Administrators

When the conversion from 2.1.x was done, were the database tables updated to add the additional table fields and new tables?

 

To quickly see -

  • In the Schedules table, are columns for week1, week2, week3, week4 ?
  • Is there a Ledger table?
  • There are several other items added to the 5.5.2 database

 

Link to comment
Share on other sites

  • Administrators

OK - that's good.

 

Can you try setting up a development site with a new install of phpVMS 5.5.2 and see if it works? Leave our live site alone for now. Run the dev site on the same host in a different directory.

Link to comment
Share on other sites

  • Administrators

Make a backup of your database and marry that backup database to this new install. Test to see if its working. If so, add you skin and then slowly add any addon modules you use. If its still all working, change the new install to your old live database and redirect your domain to the new install location. If all that goes well, you now have a new install with your original database that is working as intended.

 

If it doesn't work as you are doing the steps, investigate the last item you did which caused the issue to return.

Link to comment
Share on other sites

Married the old database to the new install. No skin installed yet. Got this first error:

 

Notice: The template file "/home/teaceo/public_html/dev//lib/skins/CURRENT_SKIN/header.php" doesn't exist in /home/teaceo/public_html/dev/core/classes/TemplateSet.class.php on line 231

 

I don't have a skin called "CURRENT_SKIN" and also there are 2 "//" before lib/skins/...

Link to comment
Share on other sites

  • Administrators

CURRENT_SKIN refers to the skin selected in the admin panel. If no addon skin installed, that means the crystal skin. But the crystal skin doesn't have a header.php file. I bet the old db is set for your addon skin instead of crystal.

 

Go to admin panel and set the skin to crystal. Or if you can't get to admin panel, go into the active db Settings table and change the skin name there.

Link to comment
Share on other sites

Ok, thanks, did it and that is solved.

 

I believe I may have found one possible problem, my installation started having problems accessing data...

My site is https. At the local.config.php, if I enter my SITE_URL  as https://..., the Airports and Schedules in admin area do not load (but all other admin pages do...). If I go back and change the SITE_URL to http, I get all airports and schedules correctly.

 

I'm still using default phpvms 5.5 skin.

 

Edited by Skytraveler
Link to comment
Share on other sites

  • Administrators
5 hours ago, Skytraveler said:

Ok, thanks, did it and that is solved.

 

I believe I may have found one possible problem, my installation started having problems accessing data...

My site is https. At the local.config.php, if I enter my SITE_URL  as https://..., the Airports and Schedules in admin area do not load (but all other admin pages do...). If I go back and change the SITE_URL to http, I get all airports and schedules correctly.

 

I'm still using default phpvms 5.5 skin.

 

 

Sounds like you need to double check that all "http" entries are changed to "https".

 

There is a post in the forums that discusses changing to https - but I was unable to locate it.

EDIT: Have a look at this thread.....

 

Link to comment
Share on other sites

It's now working!!!

 

I followed your advice and slowly added all my addons.

I had some code of my own added to the PIREPData.class.php, so I didn't copy this file to the new installation, I carefully looked for my customized lines of code in it, and pasted them to the existing PIREPData.class.php on the new installation. I'm not able to identify where the problem was, maybe it was on this file, maybe a bad redirection of some file from my previous http installation to my new https... Maybe both! 🙄

Anyway, your suggestion not only solved my problem, but also now my phpvms is running smoother and pages are loading faster.

 

Thanks for your support and for being available ☺️

 

Best regards.

Joao

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...