Jump to content
Omerr01

Problem connection ACARS

Recommended Posts

Hello everyone, 

In the last month Im having some weird problems with ACARS, I have smartCARS and KACARS and suddenly when the pilots wants to send their pireps into the website they getting errors. 

In smartCARS

"Pirep filling error:The virtual airlines web server didn't confirm the pirep filling property with smartcars. This doesn't always mean that the pirep wasn't filed. Please verify that the pirep was filed on the airlines website.
If it was filed, please click the cancel button on the acars tab cancel your flight. If it wasn't filed, please try again by clicking "file pirep" "

In KCARS

There is no physical error but there is some sound that the pirep isn't send to the website.

 

The weird problem in the both of them that everytime there are errors but sometimes the pirep is send to the website even with the error and sometime the pirep wasnt send to the website.

Please help me figure it out my pilots gets crazy about that. 
I thought maybe there is a problem with the host but the hosting support can't understand me if i dont give him the problem. 
Thanks everyone. 
 

Share this post


Link to post
Share on other sites

If your pirep database is in the 10's of thousands it can take a while to process, increase your database memory and fine tune the other parameters. This what we had to do and after that no problem at all.

Share this post


Link to post
Share on other sites

Hey mark,
Actually i have 33000 pireps, 
Dont really understand you can you explain yourself a little bit more? 

Like how i can increase database memory

Edited by Omerr01

Share this post


Link to post
Share on other sites

You need to edit your my.cnf configuration file for your mysql server, find the fine tuning section, MAKE A BACKUP FIRST,

 

These are my settings for guidance they may not work for you so change one thing at a time and test out.

 

#
# * Fine Tuning
#
key_buffer		= 348M

max_allowed_packet	= 16M
thread_stack		= 192K
thread_cache_size       = 8

key_buffer = 512M
table_cache = 1064
sort_buffer_size = 4M
read_buffer_size = 1M
read_rnd_buffer_size = 8M
myisam_sort_buffer_size = 64M
thread_cache_size = 8
query_cache_size = 128M
query_cache_type=1
query_cache_limit=4194304
long_query_time = 3
innodb_buffer_pool_size = 3G
# Try number of CPU's*2 for thread_concurrency
thread_concurrency = 16
table_open_cache =200
[isamchk]
key_buffer = 128M
sort_buffer_size = 128M
read_buffer = 2M
write_buffer = 2M

 

Share this post


Link to post
Share on other sites
On 9/7/2019 at 6:03 PM, mark1million said:

You need to edit your my.cnf configuration file for your mysql server, find the fine tuning section, MAKE A BACKUP FIRST,

 

These are my settings for guidance they may not work for you so change one thing at a time and test out.

 


#
# * Fine Tuning
#
key_buffer		= 348M

max_allowed_packet	= 16M
thread_stack		= 192K
thread_cache_size       = 8

key_buffer = 512M
table_cache = 1064
sort_buffer_size = 4M
read_buffer_size = 1M
read_rnd_buffer_size = 8M
myisam_sort_buffer_size = 64M
thread_cache_size = 8
query_cache_size = 128M
query_cache_type=1
query_cache_limit=4194304
long_query_time = 3
innodb_buffer_pool_size = 3G
# Try number of CPU's*2 for thread_concurrency
thread_concurrency = 16
table_open_cache =200
[isamchk]
key_buffer = 128M
sort_buffer_size = 128M
read_buffer = 2M
write_buffer = 2M

 

Where I can find this file i search all over the cpanel and the ftp and i didnt found it. 

Share this post


Link to post
Share on other sites

this is what the hosting supporter send to me : "On the shared hosting environment there isn't a way to tweak the my.cnf file only for a specific user. This could be done if you have a VPS or a dedicate server where you are not sharing resources with other users but you have them allocated only to you.

Could you provide me with a bit more information about the query that you are having and what those people advised you?

"

Share this post


Link to post
Share on other sites

Ok so that's a no go. One other thing to try is do you have the top pilot module installed. This is known to really slow down things when a pirep is sent. If you do the I can tell you a work round.

Share this post


Link to post
Share on other sites

Yeah i have toppilot module, 

i was tried to do something and still the problem wasnt solved, 

I change the name of the phpvms_pireps query to phpvms_archive_pireps . and create phpvms_pireps new one with same parameters but still the pireps is send to the system but with error. 

Share this post


Link to post
Share on other sites
On 9/9/2019 at 6:12 PM, mark1million said:

Ok so that's a no go. One other thing to try is do you have the top pilot module installed. This is known to really slow down things when a pirep is sent. If you do the I can tell you a work round.

Hey you have some ideas to solve this issue?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...