Jump to content

Googlemaps not working


Dyl1103
 Share

Recommended Posts

Hello!

 

Been out of the php_VMS game for a long time. Recently got back into it. The Live Map on our home page (www.flyhighva.net) is just showing a the white screen, and the Live Flights page itself doesn't load anything (http://flyhighva.net/index.php/ACARS) (did not work on crystal skin, either). Will not load after refresh.

 

I've went through this forum 3 or 4 times over, and went through the thread below, and followed all suggestions. Even checked the console (https://prnt.sc/utrt7v)

 

Running phpVMS version 5.5x (simpilot). The Google map in the admin center is working (when clicking "view route" on PIREPs) but not on the front page.

 

 

This is the only thing on the site that isn't working (so far that I've found...) and I've been at this for 2 days now, so I figured i'd ask for some help.

 

Thanks!

 

Edited by Dyl1103
Link to comment
Share on other sites

  • Administrators

Well, on an up note, the map does display on the PIREPS pages - http://flyhighva.net/index.php/pireps/view/3

 

It appears you haven't gotten the Google Maps API key installed though.

 

What PHP version?

What version of MySQL or MariaDB are you using?

 

Many of us have converted to Leaflet/OSM maps. There is a sticky thread with instructions to convert.

 

Additionally, I suggest you contact the developer of the skyBlue skin (209 Studios) as he may have some insight for you too.

Link to comment
Share on other sites

1 hour ago, ProAvia said:

Well, on an up note, the map does display on the PIREPS pages - http://flyhighva.net/index.php/pireps/view/3

 

It appears you haven't gotten the Google Maps API key installed though.

 

What PHP version?

What version of MySQL or MariaDB are you using?

 

Many of us have converted to Leaflet/OSM maps. There is a sticky thread with instructions to convert.

 

Additionally, I suggest you contact the developer of the skyBlue skin (209 Studios) as he may have some insight for you too.

 

 

PHP version: 7.3.6

mySQL version:  libmysql - 5.6.43

 

I have pasted the API key, and this is the line of code for that: 

 

<script type="text/javascript" src="http://maps.googleapis.com/maps/api/js?key=myapicodehere"</script>

and have also tried:

 

<script async defer src="http://maps.googleapis.com/maps/api/js?key=mykeyhere" type="text/javascript"></script>

After I posted, I found the Leaflet/OSM maps on github. Gonna give that a go tomorrow. Thanks for the advice!

Edited by Dyl1103
added code snippets
Link to comment
Share on other sites

  • Administrators

I think your biggest issue is using PHP 7.3 - phpVMS 5.5.2 is meant to run on PHP 5.5 and 5.6. You will have issues with it on other PHP versions. Check in cPanel if your host allows setting any other PHP versions than 7.3.

 

If host allows PHP 5.5 or 5.6, switch the phpVMS install to that.

If host allows PHP 7.0 - 7.2, use phpVMS 5.5.2.72.

If only PHP 7.3 or higher, wait until the release of phpVMS v7.

 

I would guess the entire hosting package defaults to PHP 7.3, but other versions are available.Look for MultiPHP Manager in cPanel.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...