Jump to content

Is it possible to load two or more sub-fleets in a CSV file of 500 routes or more? It's possible?


Recommended Posts

There is a problem with massively assigning two or more planes to many routes.
If you have 500 routes created and you create two sub-fleets, assigning each route, one by one, the two sub-fleets is a never-ending task.
If you add a single sub-fleet, when exporting the CSV file, the aircraft appears added in the subfleets column.
If you add two sub-fleets, and re-export the csv file, the second sub-fleet appears added in the column fares.
I understand that the fares column cannot contain a subfleet.

In other words:
If in a CSV file exported from Routes, you put a sub-fleet in the subfleets column and the other sub-fleet in the fares column, when you import the csv file into phpvms, you can see how the fares section contains a fleet.

Either this is wrong, or it's me who doesn't understand it.

And if I want to add three sub-blooms, the third is loaded into the fields column.
Can someone explain to me how to load two sub-fleets, one of the A320 and the other of the B738 in bulk to 500 routes.
Do I have to do it in the administration panel, one by one?

Link to post
Share on other sites

No, 

 

I mean you do not need to assign them one by one from the admin panel ... If you open the csv with excel or something like it, it makes changes to the columns.

 

You should either use another software for it, or use load data from text option in excel (instead of double clicking the csv file)

 

What you need is to separate the subfleets with semicolon like below

 

,route,notes,active,subfleets,fares,fields
,VAKUM UT54 KFK UR32 HALIL UW77 BAG UW71 TEMEL,,1,B738W-PGT;A320-PGT;A320N-PGT;A321N-PGT,YG,

 

Notice that subfleet sections starts with a comma (,) then i have 4 subfleets and they are separated with semicolons (;) and then subfleets section ends with a comma (,)

 

1,B738W-PGT;A320-PGT;A320N-PGT;A321N-PGT,Y

 

But when you double click a csv file with excel, it simply changes all commas to semicolons, thus breaking our import logic.

 

Edited by DisposableHero
Link to post
Share on other sites

SOLVED. I open the CSV file with LibreOffice Calc and in the Subfleets column I write all the sub-fleets separated by POINT AND COMMA; EXAMPLE: A320-200-NEO; B738W-NG; B787-10; All the text is written within the same cell, the one destined to the subfleet

  • Like 2
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...