Jump to content
SeanM

Couple Questions

Recommended Posts

Got everything installed. 2 problems when trying to upload a avatar it gives me an error "PHP Fileinfo extension must be installed/enabled to use Intervention Image." which I assume is installed as I am using VMS hosing. I am using php 7.3.

Secondly the cron job is doing my head in, "There was a problem running the cron; make sure it's setup and check logs at storage/logs/cron.log. See the docs" Mind you there is no log there. I assume this is the correct format when creating it in cpanel:  

blusquar php /blusquar/phpvms/artisan schedule:run >> /dev/null 2>&1

Share this post


Link to post
Share on other sites

There's no log because it's not running the cronjob. You have to ask your host the correct path to PHP for setting it up. I try to guess what that path is in the cronjob page. It would look something like:

 

php /blusquar/phpvms/artisan schedule:run >> /dev/null 2>&1

 

Share this post


Link to post
Share on other sites

Yeah, tried that one no luck... I can create a ticket... using your hosting so was avoiding a ticket if possible.

Share this post


Link to post
Share on other sites
1 hour ago, SeanM said:

Yeah, tried that one no luck... I can create a ticket... using your hosting so was avoiding a ticket if possible.

 

Ah, yeah, create a ticket. You've switched to PHP 7.4 already in cPanel? What's the command line that phpvms shows?

Share this post


Link to post
Share on other sites
2 minutes ago, Nabeel said:

 

Ah, yeah, create a ticket. You've switched to PHP 7.4 already in cPanel? What's the command line that phpvms shows?

Only 7.3 is avail... not sure if that matters...

Command line: * * * * * cd /home/blusquar/phpvms && /opt/cpanel/ea-php73/root/usr/bin/php-cgi -d register_argc_argv=On artisan schedule:run >> /dev/null 2>&1 thos what your referring to?

Share this post


Link to post
Share on other sites
2 minutes ago, SeanM said:

Only 7.3 is avail... not sure if that matters...

Command line: * * * * * cd /home/blusquar/phpvms && /opt/cpanel/ea-php73/root/usr/bin/php-cgi -d register_argc_argv=On artisan schedule:run >> /dev/null 2>&1 thos what your referring to?

 

Ah yes, 7.3 is fine. Try using this for the cron:

 

cd /home/blusquar/phpvms && /opt/cpanel/ea-php73/root/usr/bin/php-cgi -d register_argc_argv=On artisan schedule:run

 

Share this post


Link to post
Share on other sites

Awesome, that worked. Any idea on Intervention\Image\Exception\MissingDependencyException

PHP Fileinfo extension must be installed/enabled to use Intervention Image.

 

I am pretty sure all dependencies are working.

Share this post


Link to post
Share on other sites

That looks like a problem on my end, let me fix that. Didn't know that was a required dep for Intervention

Share this post


Link to post
Share on other sites

Ok, give it a try now. I made a bug report to add fileinfo as a required PHP extension

Share this post


Link to post
Share on other sites

That did it, pictures are not loading but that could be any number of things on my side. Thanks for the help on all that.

Edited by SeanM

Share this post


Link to post
Share on other sites
17 minutes ago, SeanM said:

That did it, pictures are not loading but that could be any number of things on my side. Thanks for the help on all that.

 

Awesome, no problem.

Share this post


Link to post
Share on other sites

For what it maybe worth, I have been dealing with this for hours and finally got it to work. My host is Hostgator and this is what worked for me in the cron command

/opt/cpanel/ea-php73/root/usr/bin/php /home1/username/public_html/artisan schedule:run >> /dev/null 2>&1

Share this post


Link to post
Share on other sites
9 hours ago, Cloudpanda said:

For what it maybe worth, I have been dealing with this for hours and finally got it to work. My host is Hostgator and this is what worked for me in the cron command

/opt/cpanel/ea-php73/root/usr/bin/php /home1/username/public_html/artisan schedule:run >> /dev/null 2>&1

 

What did the maintenance page in the admin recommend for the command?

Share this post


Link to post
Share on other sites
5 hours ago, Nabeel said:

 

What did the maintenance page in the admin recommend for the command?

This is what it shows - * * * * * cd /home1/panda/public_html && /opt/cpanel/ea-php72/root/usr/bin/php-cgi -d register_argc_argv=On artisan schedule:run >> /dev/null 2>&1

Share this post


Link to post
Share on other sites
7 hours ago, Cloudpanda said:

This is what it shows - * * * * * cd /home1/panda/public_html && /opt/cpanel/ea-php72/root/usr/bin/php-cgi -d register_argc_argv=On artisan schedule:run >> /dev/null 2>&1

 

Interesting... but the command line you're using is PHP 7.3? I think I need to change how it's launched there (without the cd)

Share this post


Link to post
Share on other sites
4 hours ago, Nabeel said:

 

Interesting... but the command line you're using is PHP 7.3? I think I need to change how it's launched there (without the cd)

Yes 7.3. the host doesnt offer 7.3 unless someone ask for it and they were able to update. They did advise 7.4 was coming soon. I tried it with the added  (cd) along with the other text in the line just to try and it accepted that too. I am very new to doing any of this. Lots and trial and error. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...