Jump to content

kACARS_Free - "No Flight Found!"


Recommended Posts

  • Administrators



PHP: 7.2

MariaDB: 10.2.44

Hosted at: vmshost


"No Flight Found!" when attempting to retrieve a schedule.


Can log in fine and connect to FS.


This is at a friends site that I have full access to. I can log into kACARS_Free but not retrieve the flight data.

receive.xml shows flightStatus 2 - which triggers the "No Flight Found!" in kACARS.


The schedule is in the DB and enabled.

The aircraft is in the DB and it's ID shown in the schedule. Aircraft is enabled.

The airline is in the DB and enabled.

The airports are in the DB.


This same version of kACARS_Free works fine on my own site.

The only difference is that I have MySQL 5.7.41 instead of MariaDB 10.2.44

My site is hosted elsewhere.


I compared his kACARS_Free site module to mine and they are exactly the same.


Anyone have a clue where to look or how to fix this issue?



Link to comment
Share on other sites

Does it happen with just a certain schedule or all? It is possible the DB version is causing some funkiness to happen, but it logging in seems to mean that it is not the DB version causing it, as if it was, you wouldn't be able to log in either. Make sure the flight number is being put in exactly like it is in the DB, and that stray numbers are not added by you or something else. Try deleting the kacars_free module and data class file and upload the ones from your site from a one you know works. Also try reducing the PHP version to 7.1 it is possible that that is causing it too. Try to see if there are any errors in the error_log file to see if that sheds any light on it.

Link to comment
Share on other sites

  • Administrators


Yeah, Ithought it was weird being able to log in but not retrieve flights.

Already tried php 7.0 and 7.1 without success.

Also tried multiple flight numbers - no spaces or odd characters - double and triple checked.

No errors show in the error_log file. Error logging is on, but not sure how vmshost is set up for logging of errors. Something more to look at there.

Every flight number entered, when requesting the flight info, the receive.xml show flightStatus2. Same if I bid a flight and change kACARS to not use Search by Flight #.


Great idea about trying my working kACARS module file and data class file - something to try over the weekend.


One other thing is I can set up a charter flight and start it.

Link to comment
Share on other sites

  • Administrators

I can bid on a flight, but it won't load in kACARS.

The bid shows in the bid table.


Hoping to have time tomorrow to swap the files out and see if that fixes it.


Barring that working, I can download his site and upload to my host to check if it works there.


As far as I know, no one else at vmshost has reported an issue with 5.5.2 or and kACARS_Free.

Link to comment
Share on other sites

  • Administrators

A little "progress"

In comparing the send.xml files when connected to his site and then connected to my site, his doesn't fully populate the send.xml with all the data for the selected flight.

Now to find out why......


Oddly, this shows below the ACARS Map on his site. It's the correct data for the flight I put in kACARS. Notice the pilot number is incorrect (happens with any pilot).


Link to comment
Share on other sites

Looks like it is not assigning the login to any pilot, or is not fully logging the pilot in. I had that happen to me before. It is possible that the php version is incorrect for kacars free Try a lower php version, when someone is using it, check the db and see what it says for the flight, also try clearing the acars table, use the reset acars table in the admin of the site.

Link to comment
Share on other sites

  • Administrators

Thanks, I will try resetting the acars table.

I noticed his acars table is quite long, so may be some bad data there.


PHP version is 7.2 - I also tried 7.0 and 7.1 without success.

On my site, it works just fine with 7.2


Also uploaded his site files and DB to my hosting. kACARS_Free still doesn't work with his files and DB on my host. So it's not his host, it's something in his files or database.

Link to comment
Share on other sites

  • Administrators

UPDATE - I married an older DB backup  from May 2022 to his site files. kACARS works as it should.


This means the site owner compromised the DB while adding schedules, aircraft, airports, etc. thru the admin panel - most probably the schedules table has numerous errors in it.

I am hoping he kept good logs of exactly what he did.


Just another reason to ALWAYS do a backup of your DB and site files anytime you change anything........


Thanks to all who offered help/advice - both here and on Discord - with this issue!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...