Jump to content
flyalaska

White Page on phpVMS 2

Recommended Posts

I am trying to get my site ready for php7. I have installed phpVMS 2 on a dev directory. Changed the skin files from php to tpl and all I get is a blank white page. Am I missing something?

Skin shows on default skin and different tpl skin. Just not the one I am trying to convert.

Edited by flyalaska

Share this post


Link to post
Share on other sites

Its not compatible with v7 or 7.1, first change your local config to use mysqli and then you have to debug the rest as you go, some common errors are filing a pirep it errors with no schedule add manually amoungst loads of other issues.

 

I have not yet been able to run this as a viable option on php v7 or 7.1 I have something running but its far from being an option with all the different addons 

Share this post


Link to post
Share on other sites

I am still on php5.6. Waiting to get the site working. Than will upgrade to php7.

Skin shows on default skin and different tpl skin. Just not the one I am trying to convert.

Edited by flyalaska

Share this post


Link to post
Share on other sites

I am running on 5.6 ok with a bit of messing about, I think my VA's will probably cease when my host goes to php7 as i just can not convert everything i have over. The only option i have is to create a dedicated server with php5.4 or 5.6 and maintain it at that version.

Share this post


Link to post
Share on other sites
7 hours ago, mark1million said:

Its not compatible with v7 or 7.1, first change your local config to use mysqli and then you have to debug the rest as you go, some common errors are filing a pirep it errors with no schedule add manually amoungst loads of other issues.

 

I have not yet been able to run this as a viable option on php v7 or 7.1 I have something running but its far from being an option with all the different addons 

I disagree, I'm running 5.5.x on a PHP 7.0 dev environment locally and I've only had two issues so far, one being that it requires PHP 5.x.x on install and the other being the reCaptcha class needs to be named __construct instead of the class name as it's deprecated in PHP 7.0+. This was only a base install with a few modules though.

As for phpvms 2 on PHP 7.0, https://forum.phpvms.net/topic/24500-phpvms-legacy-support-for-php-7/ is about as far as I know for it. Check your folder permissions and error_log file for any further info.

Edited by web541

Share this post


Link to post
Share on other sites
3 hours ago, web541 said:

I disagree, I'm running 5.5.x on a PHP 7.0 dev environment locally and I've only had two issues so far, one being that it requires PHP 5.x.x on install and the other being the reCaptcha class needs to be named __construct instead of the class name as it's deprecated in PHP 7.0+.

As for phpvms 2 on PHP 7.0, https://forum.phpvms.net/topic/24500-phpvms-legacy-support-for-php-7/ is about as far as I know for it. Check your folder permissions and error_log file for any further info.

I dont know what addons you have nut i have loads of them and custom coded and they will not work, i can run base install no problems but when i start adding addons its all goes to pot.

 

I have just deployed a new server for testing and working out the new way of phpvms currently in dev, im not going to waste any more time on 5.3, 5.4,  5.5 or 5.6 compatibility, there is just too much work to get it all together.

Share this post


Link to post
Share on other sites
1 hour ago, mark1million said:

I dont know what addons you have nut i have loads of them and custom coded and they will not work, i can run base install no problems but when i start adding addons its all goes to pot.

 

I have just deployed a new server for testing and working out the new way of phpvms currently in dev, im not going to waste any more time on 5.3, 5.4,  5.5 or 5.6 compatibility, there is just too much work to get it all together.

Yeah, my installation wasn't overloaded, it only had about 3 modules installed. They will probably cause issues as you stated, I didn't think of that.

Share this post


Link to post
Share on other sites

I have 0 modules. Installing a fresh skin. Crystal shows up. My other skin wont. Thats why I am asking if I am missing something. The skin files have been changed to .tpl

Share this post


Link to post
Share on other sites

I would change the skin files to .php, enable logging of errors and look in the server logs and work through the errors you get.

 

Comment out the includes if you have any and any added modules, thats a good place to start.

Share this post


Link to post
Share on other sites

Because I have my layout and core navigational split I had an error with this once pointing to .php instead of .tpl, it's something to check and easy to over look!

 

                                            <?php Template::Show('core_navigation.tpl'); ?>

Hope you find the problem, and get it fixed!
 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...