Jump to content
Tw3nty4

Tables wont install

Recommended Posts

Hi there,

I have been trying to install PHPVMS 5.5 on my web server and can't seem to get past the installing tables part, what I get is just a blank screen, I have all the files on the domain I have listed, have looked at the install checker and its saying files are missing yet I see them clearly in the ftp browsers. Ive been at trying to get this on my server for the last 3 hours and its not happy with me any help would be great, thanks. 

Share this post


Link to post
Share on other sites

so i read up on the phpms for dummies page and fixed the blank page but now im getting this code


Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /home/anthroai/public_html/Crew/phpvms/core/classes/ezdb/ezdb_mysql.class.php:98 Stack trace: #0 /home/anthroai/public_html/Crew/phpvms/core/classes/ezdb/ezdb.class.php(195): ezDB_mysql->connect('anthroai_vms', 'JHw0w0U$#Pd^', 'localhost') #1 /home/anthroai/public_html/Crew/phpvms/install/includes/Installer.class.php(148): DB::connect('anthroai_vms', 'JHw0w0U$#Pd^', 'anthroai_phpvms...', 'localhost') #2 /home/anthroai/public_html/Crew/phpvms/install/install.php(49): Installer::AddTables() #3 {main} thrown in /home/anthroai/public_html/Crew/phpvms/core/classes/ezdb/ezdb_mysql.class.php on line 98

Edited by Tw3nty4

Share this post


Link to post
Share on other sites

Did any of the tables in the database populate?

/home/anthroai/public_html/Crew/phpvms/core/classes/ezdb/ezdb_mysql.class.php on line 98

Here's my line 98

$this->dbh = @mysql_connect($dbhost, $dbuser, $dbpassword, true);

The function is trying to connect to MySQL - but not a database. It's possible that it's not able to access your MySQL - maybe something to due with your hosting settings??

Share this post


Link to post
Share on other sites

so i ended up install version 7, is there a way to put custom flight plan files in like the old version or does it have to be put in manually, they are set up as what is needed im just wondering do we have manually add them

 

Share this post


Link to post
Share on other sites
2 hours ago, Tw3nty4 said:

so i ended up install version 7, is there a way to put custom flight plan files in like the old version or does it have to be put in manually, they are set up as what is needed im just wondering do we have manually add them

 

V7 is not a stable release yet.

Share this post


Link to post
Share on other sites
8 hours ago, Tw3nty4 said:

so your saying back down to 5.5

Yes, you should use phpVMS 5.X for a virtual airline at this point, as v7 is still being developed, and is still in the testing stages. You CAN install v7 just to have a look around, but there are still thing's to be worked out. Have no idea when v7 will be in major release to public, but if you like learning thing's you should TRY v7, just to mess around! But NOT for production of an actual VA!

Share this post


Link to post
Share on other sites

so i backed down to phpvms v5 and it keep giving me Fatal error: Class 'mysqli' not found in /home/anthroai/public_html/crew2/core/classes/ezdb/ezdb_mysqli.class.php on line 97 any help
$this->dbh = new mysqli($dbhost, $dbuser, $dbpassword , true);

Edited by Tw3nty4

Share this post


Link to post
Share on other sites

I am experiencing the exact same issue. So I know that there were a lot of changes in MySQL 5.7 that are breaking applications across the board

has anyone tried disabling strict mode, or downgrading from 5.7 back to 5.5 or 5.6v

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×