Jump to content
aboud

Installation Error

Recommended Posts

Hello,

I am using shared hosting [ionos] and trying to install phpvms7. I downloaded the tar from github and uploaded to ftp public folder. when I go to my domain I get PHPvms not installed, head to install. I click on head to install but I get Internal Server Error.

I am using php version 7.2 and here is my .htaccess file ( it is the same on root and public_html folder ) 

 

htaccess.zip

Share this post


Link to post
Share on other sites

All those 403 entries may be your problem. Back up both references to the .htaccess files, open the original and delete or comment out all the 403 entries, saved the edited .htacess files. Try the install again.

I'm assuming you realize that phpVMS v7 is still in beta and should not be used for a production/live siite.

Edited by ProAvia

Share this post


Link to post
Share on other sites

I have tried deleting 403 comments, but still internal server error. I am aware that it is still in BETA but it is just for testing.

Share this post


Link to post
Share on other sites

So, you upload all the files and can access the initial install page using your browser?

And you have removed all 403 entries in all .htaccess files in the path from the root to the directory containing the phpVMS v7 files/folders?

Share this post


Link to post
Share on other sites

Here is the present error

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

I was incorrect in having you disable those entries. The 403 entries I referenced above should stay active in the phpvms v7 folders .htaccess file. Here are those contents for reference:

# Disable index view
Options -Indexes

RewriteEngine On

# Handle Authorization Header
RewriteCond %{HTTP:Authorization} ^(.*)
RewriteRule .* - [e=HTTP_AUTHORIZATION:%1]

# Deny all these files/folders
RedirectMatch 403 ^/.git/.*?$
RedirectMatch 403 ^/.travis/.*?$
RedirectMatch 403 ^/app/.*?$
RedirectMatch 403 ^/bootstrap/.*?$
RedirectMatch 403 ^/config/.*?$
RedirectMatch 403 ^/modules/.*?$
RedirectMatch 403 ^/node_modules/.*?$
RedirectMatch 403 ^/resources/.*?$
RedirectMatch 403 ^/storage/.*?$
RedirectMatch 403 ^/tests/.*?$
RedirectMatch 403 ^/vendor/.*?$
RedirectMatch 403 ^/.bowerrc$
RedirectMatch 403 ^/artisan$
RedirectMatch 403 ^/composer.json
RedirectMatch 403 ^/composer.lock
RedirectMatch 403 ^/composer.phar
RedirectMatch 403 ^/env.php.*?$
RedirectMatch 403 ^/env.php
RedirectMatch 403 ^/env.php$
RedirectMatch 403 ^/Makefile
RedirectMatch 403 ^/package.json
RedirectMatch 403 ^/package-lock.json
RedirectMatch 403 ^/phpunit.xml
RedirectMatch 403 ^/webpack.mix.js

# Redirect Trailing Slashes If Not A Folder...
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)/$ /$1 [L,R=301]

# Handle Front Controller...
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^ index.php [L]

Possibly check your server error log for further clues. I'm guessing something may be configured incorrectly on your server. Hopefully someone with more experience than me will be along to help you out.

Edited by ProAvia

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...