Jump to content
nicky9499

phpvms7 install git fatal error [RESOLVED]

Recommended Posts

singap08@ams-node4 [~]# cd public_html
singap08@ams-node4 [~/public_html]# cd phpvms
singap08@ams-node4 [~/public_html/phpvms]# git clone git@github.com:nshahzad/phpVMS.git .
Cloning into '.'...
Permission denied (publickey).
fatal: Could not read from remote repository.

Encountered the above error while following the below instructions.

Please advise and/or rectify asap, thank you.

https://forum.phpvms.net/tutorials/getting-started/installation-r2/

Additionally there is a second set of instructions that are completely different

http://docs.phpvms.net/setup/installation

So which one do I follow?

Share this post


Link to post
Share on other sites

This is in the phpVMS v7 forum (which isn't completely stable yet). If you want a current, working version of phpVMS then I suggest uploading this https://github.com/DavidJClark/phpvms_5.5.x to your server and making sure your PHP version is compatible.

If you are looking for phpVMS v7 to install, then follow these instructions http://docs.phpvms.net/setup/installation and just by chance, are you using ssh on your server?

Share this post


Link to post
Share on other sites

I was thinking v7 would be suitable for the long term since the v5 to v7 migrator still has issues and v7 itself it reasonably complete.

If this isn't the case feel free to advise, since I haven't done much at all and can go back to install v5.

Yes, I have tried both PuTTY and the Terminal from my cPanel both throw the same error.

Can the git be obtained manually from github and uploaded to my server somehow?

Share this post


Link to post
Share on other sites
7 minutes ago, nicky9499 said:

I was thinking v7 would be suitable for the long term since the v5 to v7 migrator still has issues and v7 itself it reasonably complete.

Really, it's up to you. The migrator should be fixed provided a stable version of v7 has officially been released. I believe it already migrates pilots, pireps, schedules and fleet across to some extent and the functionality will continue to be improved for the release as far as I'm aware.

9 minutes ago, nicky9499 said:

Can the git be obtained manually from github and uploaded to my server somehow?

Check here https://forum.phpvms.net/topic/26778-700-beta-2/ that should give you the entire git with the vendor folder extracted. Bear in mind that it will need to be updated manually when Nabeel releases the next official version.

  • Like 1

Share this post


Link to post
Share on other sites

Hi Mate thanks again for the quick reply.

Not sure how I missed it previously but v7 requires php 7 and above.

While I can easily upgrade, the forums hosted on the same server is not compatible with php 7.

For now we will try out phpvms5.

Edited by nicky9499

Share this post


Link to post
Share on other sites

Just a quick question, I am getting this right after install. Have looked in the file itself but date cannot be found at line 201 or anywhere in the document.

Warning: strtotime(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in /home/singap08/public_html/operations/core/classes/CodonCache.class.php on line 201

The same error is plastered all over the page at http://www.singaporevirtualairlines.org/operations/

Edited by nicky9499

Share this post


Link to post
Share on other sites
On 1/6/2020 at 3:38 PM, Nabeel said:

How did you resolve it?

He cloned the repository via ssh so the solution is add the ssh key.

Other way to clone avoiding this error is ussing HTTPS method instead of SSH

Share this post


Link to post
Share on other sites

I didn't do that, it sounds far too complicated for my skill level. A quick google search turned up this thread which offered a quick fix.

Sorry for not updating properly for posterity.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...