Jump to content

Simbrief Intregation Problems new URL [SOLVED]


Virtualei
 Share

Recommended Posts

Hi

Wondering if anyone can help. I have done a new skin for my VA deciding to change from the Icrew Skin. When my VA used the Icrew its URL was crew.virtualei.net

With my new skin I have gone back to the parent URL virtualei.net

My problem is that my simbrief button is not working. I uninstalled the module and all the files and did a fresh install remembering to put in the new URL and my API in the correct files. When I click on the. When I inspect for console errors it is still saying crew.virtualei.net as per screenshot. I have cleared my PC cache and history but it doesnt work. I am at a total loss. Any help appreciated.

 

https://prnt.sc/svd4ud

 

 

Link to comment
Share on other sites

  • Administrators

Which means the API key is tied to virtualei.net - so anything that point that domain will work with the API key.

 

I would double check all the simBrief files again. Also verify the SITE_URL in local.config.php is shown as https and not http. I think its around line 27 in local.config.php

Link to comment
Share on other sites

3 minutes ago, ProAvia said:

Which means the API key is tied to virtualei.net - so anything that point that domain will work with the API key.

 

I would double check all the simBrief files again. Also verify the SITE_URL in local.config.php is shown as https and not http. I think its around line 27 in local.config.php

Thanks again for your reply. HTTPS is used in my local config file ok. I deleted all the files again and re-installed thembut still the same problem. My head is turned :( I have written to Derek again to see if he would issue a new key just even to put my mind at ease

Link to comment
Share on other sites

hi

 

You have a SimBrief file present in your skin (lib / skins / your_name_skin / SimBrief /?

normally in the SimBrief folder placed in "core / modules /" you have the SimBriefk file, do you have the right path for your .tpl ?

$this-> render ('SimBrief / SimBrief.tpl');

be careful, respect if you have capital letters in your folder and file names?

Link to comment
Share on other sites

2 minutes ago, PetitJedi said:

hi

 

You have a SimBrief file present in your skin (lib / skins / your_name_skin / SimBrief /?

normally in the SimBrief folder placed in "core / modules /" you have the SimBriefk file, do you have the right path for your .tpl ?


$this-> render ('SimBrief / SimBrief.tpl');

be careful, respect if you have capital letters in your folder and file names?

Yes I had copied that out of my Core/templates folder to try something . I have removed that file now and the original file is still in the correct place. Thanks :)

Link to comment
Share on other sites

/*
* Modify this variable if your "simbrief.apiv1.php" file is not located in the
* same directory as your Dispatch Options page.
*/

var api_dir = 'https://www.virtualei.net/index.php/core/modules/SimBrief/'; //Ex. "some/directory/";

This is from my JS file

 

Link to comment
Share on other sites

I am really starting to think it is the API. I have again deleted all the file and re-installed them. Still getting the same error. Interestingly though when I check my sources on my site i get this 

 

https://prnt.sc/sw0r8e

 

but this is the code I have on my cpanel

 

* SimBrief APIv1 Javascript Functions
* For use with VA Dispatch systems
* By Derek Mayer - contact@simbrief.com
*
* Any individual wishing to make use of this class must first contact me
* to obtain a unique API key; without which it will be impossible to connect 
* to the API.
*
* Any attempt to circumvent the API authorization, steal another 
* developer's API key, hack, compromise, or gain unauthorized access to 
* the SimBrief website or it's web systems, or bypass or allow others to bypass
* the SimBrief.com login screen will result in immediate revocation of the
* associated API key, and in serious situations, legal action at my discretion.
*/


/*
* Modify this variable if your "simbrief.apiv1.php" file is not located in the
* same directory as your Dispatch Options page.
*/

var api_dir = 'https://www.virtualei.net/core/modules/SimBrief/'; //Ex. "some/directory/";



/*
* Settings and initial variables
*/

I will wait and see if Simbrief get back to me witha new key unless anyone else has any ideas

 

Thanks

 

Alan

Link to comment
Share on other sites

21 minutes ago, Strider said:

Are you uploading the right file? As I think you may be uploading the old file instead of the new one.

 

 

Hmm possible mate. Getting it now of GITHUB . They are TPL files for the templates but I am changing them to php

Edited by Virtualei
Link to comment
Share on other sites

  • Administrators

Here's something to check also....

 

Go through each and every simBrief file and change http to https.

This applies to the original simBrief module and to the options form too if you use it.

And check that you have the correct URL near the bottom of the options form file "schedule_briefing.php".

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...