Jump to content

Can´t add more than 30 aircrafts in Admin


mt007
 Share

Recommended Posts

Hi guys,

i can´t add more than 30 planes in Admin, its normal?

 

I try add more and see this error message: 

There was an error adding the aircraft

 

But in list i can add 30 planes without problems.

 

I use this version: phpvms_5.5.x

 

Any idea?

Thanks for help.

 

Regards,

Miguel

 

Link to comment
Share on other sites

  • Moderators

Maybe the aircraft table of your database is currepted or there is an issue the primary/foreign keys. Would you like to pm me your cpanel/phpvms details to check it out for you? As soon as I check it, I will post the solution so the community is aware of the issue and the resolution of it.

Link to comment
Share on other sites

On 11/22/2020 at 1:19 PM, servetas said:

Maybe the aircraft table of your database is currepted or there is an issue the primary/foreign keys. Would you like to pm me your cpanel/phpvms details to check it out for you? As soon as I check it, I will post the solution so the community is aware of the issue and the resolution of it.

 

I have send PM to you.

Thanks

Miguel

Link to comment
Share on other sites

  • Administrators

Are you using phpVMS 5.5.2 or 5.5.2.72?

 

PHP version?

MySQL or MariaDB version?

 

Do you have error reporting on?
Any errors in the error_log files?

 

I'd be willing to bet it may be a strict mode issue - but need more info from you.... see questions above.

 

Link to comment
Share on other sites

19 hours ago, ProAvia said:

Are you using phpVMS 5.5.2 or 5.5.2.72?

 

PHP version?

MySQL or MariaDB version?

 

Do you have error reporting on?
Any errors in the error_log files?

 

I'd be willing to bet it may be a strict mode issue - but need more info from you.... see questions above.

 

 

phpVMS versin: Version simpilot 5.5.2

PHP Version: 7.2

MySQL or MariaDB version: MySQL i think.

 

Im very sorry, but aircraft now works fine and i don´t know why..

 

In Admin:
Schedule continue don´t working.

After i add a flight, i see this message: Flight "xxx" Added, on green colour, but in table list (view Schedules) nothing apear. 

In public area i see this message: "No routes have found!"

 

Any idea ?

 

Thanks very much for help.

Regards,

Miguel

 

Edited by mt007
Link to comment
Share on other sites

  • Administrators

One of your issues is using phpVMS 5.5.2 with PHP 7.2. That will certainly cause issues. That is why there is phpVMS 5.5.2.72 - which is compatible with PHP 7.0 thru 7.2 .

 

What version of MySQL? Is probably 5.6 or 5.7 . If MariaDB, is probably 10.1, 10.2 or 10.3.

 

Sounds lime you don't have error reporting on. If it were on, you would see errors when using phpVMS 5.5.2 with PHP 7.2.

 

See if your host offers PHP 5.6 as it's compatible with phpVMS 5.5.2

Link to comment
Share on other sites

Im try PHP 5.6, and schedule no work neither.

 

I see this error:

 

There was an error adding the schedule, already exists DB error: Field 'route_details' doesn't have a default value

 

and

 

There was an error adding the schedule, already exists DB error: Incorrect double value: '' for column `vpoaf_vms`.`phpvms_schedules`.`price` at row 1

 

I have no ideas.

 

What do you suggest to install? From zero.

 Thanks.

 

Miguel

Edited by mt007
Link to comment
Share on other sites

  • Administrators

Make sure every field in the schedule has something in it - even if that something is a 'space'. I have had to do this for schedules before - if you don't use departure or arrival times, or have other fields that are vlank... enter a space (press spacebar one time) or enter another alphanumeric character. For the pricefield, enter a 0 (zero) if you don't have a price there. That will usually solve that issue.

Link to comment
Share on other sites

  • Administrators

Glad you got it working.

 

There are several freeware ACARS around - as well as a couple payware options.

Freeware - kACARS_Free, CCFTracker and others

Payware - smartCARS

These are the ones I know of. A forum search make provide additional options.

Link to comment
Share on other sites

22 hours ago, ProAvia said:

Glad you got it working.

 

There are several freeware ACARS around - as well as a couple payware options.

Freeware - kACARS_Free, CCFTracker and others

Payware - smartCARS

These are the ones I know of. A forum search make provide additional options.

 

Hi ProAvia,

- Live map in Crystall, no traffic.

Im connected using cACARS but no see my plane in live map.

 

 

I make this changes like here https://gist.github.com/nabeelio/8b7ab29fb67dfe27284d63d7136388dc

But no traffic.

 

- And final flight i send Pirep, see message Pirep sent to VA, but then in ADMIN or Pilot Center no pirep too.

 

Any idea?

Thanks my friend.

 

Miguel

Edited by mt007
Link to comment
Share on other sites

  • Administrators

Did you install the cACARS module on your site?

I am not familiar with cACARS. Does cACARS show it is connected to your site?

 

Make sure error reporting it turned on in your hosting settings. 

Check the local.config.php file and post the entry for error reporting here.

Link to comment
Share on other sites

22 hours ago, ProAvia said:

1 - Did you install the cACARS module on your site?

2 - I am not familiar with cACARS. Does cACARS show it is connected to your site?

 

3 - Make sure error reporting it turned on in your hosting settings. 

4 - Check the local.config.php file and post the entry for error reporting here.

 

Hi ProAvia,

1 - Yes and with kACARS happen the same problem.

I received emails from hosting or vms with report .

But in Admin nothing to accept and in pilot center no report exist

 

2 - yes both programs, cACARS and kACARS connect (in url we must put http://www.website.com/vms/ or http://www.website.com/ ??????

3 - how i do it?

4 - what do you mean?

 

 

I see log (core/logs/log.txt) and see this error: 

Time: 12.01.20 13:43:39
Backtrace: DB::write_debug > DB::query > ACARSData::updateFlightData > CCFTracker->posrep > call_user_func_array > MainController::RunAllActions
Query: INSERT INTO phpvms_acarsdata (`pilotid`,`flightnum`,`pilotname`,`aircraft`,`lat`,`lng`,`heading`,`alt`,`gs`,`depicao`,`arricao`,`deptime`,`arrtime`,`route`,`distremain`,`timeremaining`,`phasedetail`,`online`,`client`,`depapt`,`arrapt`,`lastupdate`) VALUES ....... all correct but at end i see this: Error: (1364) - Field 'route_details' doesn't have a default value

 

in mysql table phpvms_schedules Default is NULL and are wright this inside field route_details a:0:{}

 

Thanks for your time.

Regards,

Miguel 

 

Edited by mt007
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...