Jump to content
ACTCVA

kAcars Error

Recommended Posts

Hi, I have tried to use kAcars with my VA but when I attempt to log in (with the correct details in the settings area) it gives me the following error:

Website Warning Encountered

Notify system administrator of the switch error.

Data not recieved

switch = verify

What does this mean and how can I fix it?

Regards,

ACTCVA

Share this post


Link to post
Share on other sites
Guest lorathon

This means that kACARS_Free is not receiving a response from your site. I would check your settings again. If you continue to have issues please send me your site address and I will see what I can do.

Share this post


Link to post
Share on other sites
Guest lorathon

Your hosting provider is returning extra data in the xml file.


<sitedata><info><loginStatus>0</loginStatus></info></sitedata>

<!-- www.000webhost.com Analytics Code -->
<script type="text/javascript" src="http://analytics.hosting24.com/count.php"></script>
<noscript><a href="http://www.hosting24.com/"><img src="http://analytics.hosting24.com/count.php" alt="web hosting" /></a></noscript>
<!-- End Of Analytics Code -->

You will need to talk to your host. The xml return needs to be clean.

Share this post


Link to post
Share on other sites

Your hosting provider is returning extra data in the xml file.


<sitedata><info><loginStatus>0</loginStatus></info></sitedata>

<!-- www.000webhost.com Analytics Code -->
<script type="text/javascript" src="http://analytics.hosting24.com/count.php"></script>
<noscript><a href="http://www.hosting24.com/"><img src="http://analytics.hosting24.com/count.php" alt="web hosting" /></a></noscript>
<!-- End Of Analytics Code -->

You will need to talk to your host. The xml return needs to be clean.

The host your using is a free host which PHPVMS has had issues with before. Those providers usually don't have everything setup correctly. I suggest you switch over to www.fivedev.net as it is built just for PHPVMS.

Share this post


Link to post
Share on other sites

The host your using is a free host which PHPVMS has had issues with before. Those providers usually don't have everything setup correctly. I suggest you switch over to www.fivedev.net as it is built just for PHPVMS.

Will definitely consider it. Thanks for all the help guys!

Share this post


Link to post
Share on other sites
Guest lorathon

Make sure you are using the correct module (v1.0.0.9) and that it is named correctly and installed correctly.

Share this post


Link to post
Share on other sites

Hi,

I'm using the kACARS_free at 000webhost.com. I'm making the first very long flight from LPPR (Porto, Portugal) to KBOS (Boston Logan, USA) and it's working like a dream! :D

Here's how I managed to do so: Opened a ticket requesting them to remove the XML server response "garbage" that was affecting kACARS's hability to connect.

They sent me this link to disable it:

http://members.000webhost.com/analytics.php

You'll need the site full address and it's FTP password.

As it always happens, when something is disconnected on a free hosting server, it has it's own effects on other issues and this is not an exception:

The catch is that you can't have a server's visitors count, but since we are working with PHPVMS, it's done via software, so that isn't a BIG issue for us.

Happy flying!

Sérgio Gomes

PS: PIREP sending is yet to be tested. I'll get back to you on this issue.

One thing is for sure: On the presentation of my airline, you'll get to see it, but as far as kACARS flight logging on 000webhosting.com is concerned: IT WORKS! YEAH! B) B)

  • Like 1

Share this post


Link to post
Share on other sites

Did I see hosting24.com in the xml?? There the reason I switched to Fivedev. Overall experience I had with them was terrible.

Share this post


Link to post
Share on other sites

I was having problems connecting this morning too. Able to login last night but not today. Tried uninstalling reinstalling switching modules nothing worked.

Was doing a lot of testing on the site last night constantly bidding on flights logging in logging out on kacars

When I deleted the acars data from the admin center I was able to get back in.

Guessing had so much stuff in the acars database folder was preventing me from loggin in

Hope this helps

Share this post


Link to post
Share on other sites

Hi,

I'm using the kACARS_free at 000webhost.com. I'm making the first very long flight from LPPR (Porto, Portugal) to KBOS (Boston Logan, USA) and it's working like a dream! biggrin.gif

Here's how I managed to do so: Opened a ticket requesting them to remove the XML server response "garbage" that was affecting kACARS's hability to connect.

They sent me this link to disable it:

http://members.000we...m/analytics.php

You'll need the site full address and it's FTP password.

As it always happens, when something is disconnected on a free hosting server, it has it's own effects on other issues and this is not an exception:

The catch is that you can't have a server's visitors count, but since we are working with PHPVMS, it's done via software, so that isn't a BIG issue for us.

Happy flying!

Sérgio Gomes

PS: PIREP sending is yet to be tested. I'll get back to you on this issue.

One thing is for sure: On the presentation of my airline, you'll get to see it, but as far as kACARS flight logging on 000webhosting.com is concerned: IT WORKS! YEAH! cool.gifcool.gif

Thats working like a charm. Thanks for your reply helped a lot!

Share this post


Link to post
Share on other sites

Mine doesn't connect either, I get the switch message. The url for my website is http://www.bluespiritva.co.uk

The module is correct and in the core/modules folder. The module and the client versions match and as far as I can see I've put in the settings properly. I'm not on a free host it's a paid hosting I've had for a long time.

If you can suggest anything I'd be grateful.

Share this post


Link to post
Share on other sites

Ok so i checked with my host provider and they don't add any additional script code to the files. They have basically told me that this is the fault:

[24-Jun-2013 18:21:07] PHP Fatal error: Class 'CodonModule' not found in /home5/spiritc1/public_html/bluespiritva.co.uk/airline-operations/core/modules/kACARS_Free/kACARS_Free.php on line 21

[24-Jun-2013 18:35:12] PHP Fatal error: Class 'CodonModule' not found in /home5/spiritc1/public_html/bluespiritva.co.uk/airline-operations/core/modules/kACARS_Free/kACARS_Free.php on line 21

Which I'm guessing means that kACARS_Free.php script can't communicate with the databases it needs and return any information.

I've tried everything to get this working but it still throws up the same "switch verify" issue. I'd be grateful if someone could help me sort this. Happy to pay a bit for someone's time to get it fixed. I want to get my pilots flying on the system and the other trackers just aren't good enough.

Share this post


Link to post
Share on other sites

Umm don't see an email from you. What's the name on your email? Anyways, it is kind of redundant now, I finally got it working.

After about the eighth or ninth time uninstalling it and reinstalling it!

As far as I can tell, my phpvms installation was fine, the kACARS client was fine, it was definitely something to do with the module folder and versions. So I deleted everything including the client. I downloaded the module again and extracted the folder into core/modules. I then downloaded the client and installed that. I then checked the php script which i noticed was called kACARS_Free. The folder however was called kACARS_Free module v1.0.1.1 or something. So just as a hunch I changed that folder and named it kACARS_Free so it matched the php file inside the folder.

I then started up the client and hey presto it worked! Oh, I had to alter my base url too from www.yoursite.net to www.yoursite.net/airline-operations which is where my phpvms install is

Anyways all sorted now.

Thanks

Share this post


Link to post
Share on other sites

Hi,

Hopefully this works, because my posts will need approval. But, If it is not approved, I get nothing as reply.

I want to use kACARS as my PiREP-tool. Unfortunately I get this *** error again and again. Everything I tried will return this error. I am using HostDeal (hostdeal.eu), but they can't figure it out as well. And, yes, it is a paid host.

Which error do I get?

Notify System Administrator of the Switch error.

Data not received

Switch = verify.

Now I have 2 core/module/kACARS_FREE. One in my public_html and one in my public_html/phpvms. I sure want to register and pay, but if this doesn't work, the paid version will not work either, I believe.

Hopefully you can (finally) help me!

Kind regards,

Stefan (Maanlander).

http://www.largo-aviation.eu

Share this post


Link to post
Share on other sites
Guest lorathon

NOTE - Make sure that the file inside of the module folder is named

kACARS_Free.php

Share this post


Link to post
Share on other sites

@ lorathon,

I can not figure it out. I look at the server of my host and see kACARS_Free.php in the following directory:

O:/domains/largo_aviation.eu/puvlic_html/phpvms/core/modules/kACARS_Free.

Do I need to install it? If yes, HOW can I install it? As I have seen in a tutorial, I just need to copy the file. But then it doesn't work. :'(

Hope to hear it soon from you and hope to have it working sooner. :)

Kind regards,

Share this post


Link to post
Share on other sites

Notify System Administrator of the Switch error.

Data not received

Switch = verify.

www.jaivirtual.net

Unable to install the module also.

Admin please help as soon as possible. I have switched off my analytics as well. :(

Share this post


Link to post
Share on other sites

Have the same issue with custom kACARS (and free kACARS has same result). If you get a CONNECTION ERROR (in the free version), with the "Data not received", check your server logs. If it's throwing a 406 error, the problem is with kACARS.

I spent a couple hours with my hosts tech support to track the problem down. Many hosts are implementing firewall rules that will filter webserver requests that lack a user agent header. It appears that kACARS is lacking the header in its requests. Dropping the firewall rule would impact all other users on the server, so that's not an option.

Have e-mailed Jeff, but not sure if anything will get done. In the interim, we can't use kACARS (custom or free).

EDIT: Just want to clarify this this issue (at least the one I'm experiencing, which is thrown 406 error, followed by the "Switch Error" and "Data Not received") is in fact caused by lack of a user agent header in the webserver requests. This was verified by APVA throwing the exact same error. Looking at the APVA code, the user agent property isn't set in one of the database functions. When I set the property, the webserver request returned a 200 (OK). Comment out setting the property and it throws a 406.

For reference, my host is using ModSecurity (Open Source). So, if you're having connection errors, either use Fiddler, or better yet look at your raw server logs. If you're getting 406 errors when attempting to send webserver requests, kACARS is likely the culprit.

Share this post


Link to post
Share on other sites

Hi,

I am a member of a virtual airline (not Seulawah Virtual) and I would like suggesting the management to implement the free kAcars instead FSAcars currently used by them.

When trying to fly using the kAcars I got the message as referred by many in this forum, ie:

Notify System Administrator of the Switch error.

Data not received

Switch = verify.

What can I do to correct this?

Thanks

Share this post


Link to post
Share on other sites

Do you have the correct kACARS module to match the client installed on the site? Usually that is the cause of that error.

Share this post


Link to post
Share on other sites

Do you have the correct kACARS module to match the client installed on the site? Usually that is the cause of that error.

I exactly dont know how it works, could you please elaborate a bit about "to match the client installed"

Thanks

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...