Jump to content
Tom

VAForum 2

Recommended Posts

Now that is odd. Let me do some checking real quick. Ill be right back. Bya ll rights, that has to work. Not sure why it isn't. Ill go dig for a minute

Share this post


Link to post
Share on other sites

Hey is your forums folder in core/templates or in your oceanblue skin? if the latter, for a test, try moving them to the core templates folder.

Meanwhile, i am still researching

Edited by TAV1702

Share this post


Link to post
Share on other sites

Haha! Yeah, it seems to be working as you intended! Thank you very much. Just need to go through and tweak the styling here and there!

Awesome man. Glad we got it figured out for you. :)

Share this post


Link to post
Share on other sites

**EDIT**

If you wish to see the pics an d follow along with my post, please view the images right to left. It attached them opposite how I posted about them.

--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

**Original Post**

Well, I have been on this for a little bit now. I got it all skinned out. I need to tweak a few minor things. I will point them out in each pic I post.

The first pic I posted you can see looks decent. Not professional but decent. I can't complain. And If you notice, I skinned the forum nav for my breadcrumbs too. The OCD in me could not handle the plain text.

The next pic is the topic list. Notice the breadcrumbs? Also, notice the last post and the initial post dates? All posts were made this month, not in august. ;-) Yeah, that is my next fix right after I submit this post. Also, the post new topic button needs to be up top on the fum as well. On another VA I built 4 or 5 years ago. we had LOADS of topics and we had newbies not know how to post because they did not scroll down all the way to the bottom of the page to see the post new topic button. Do yeah, it needs moved or another added.

The next image is the topic view. Yeah, my signature sucks, don't laugh! :P It is temporary. One thing I want to do is move the topic name over to the right above the post and place the date line right under it like it should be instead of the topic being over the top of my avatar. Also, I would love the avatar and user info not to push so far down. I have not looked to see if it has center enabled. If so, gone! Also notice below my user info it says contact me. I need to create a nice little button for that. I do not want to use my standard big blue button for that. Little css work and all will be well in the neighborhood. By the way that Contact me is a code snippet by someone on the forums here. I forget who bit it works pretty well.

And that is not all. I didn't feel like snapping screenies of each page. I did not cut any corners. Every single page associated with the forum is skinned accordingly. It can be done with a little work. I just wish we had a decent WYSIWYG for it that actually worked. I think no matter which one we install, such as the newest ckeditor, it is not going to work due to the html and bbcode limitations in the VA Forum2. If any of you have one that works, please let us all know. We have no way to enlarge fonts, color fonts or nothing we need to be able to do forum wise.

All in all, I do appreciate the work Dave (Simpilot) put in to bringing us this forum for phpVMS. I got to give props (how 80's was that???) to Tom for updating the forum and keeping it alive. Now only if V3 would be released. ;)

Take care boys and gents.

post-308-0-34291100-1481656891_thumb.jpg

post-308-0-34177900-1481657718_thumb.jpg

post-308-0-74671100-1481657733_thumb.jpg

Edited by TAV1702

Share this post


Link to post
Share on other sites

TAV1702,

I posted in an area about wanting to get involved with the new version of phpVMS 3, or helping and learning to create modules for the new system. Looks like you and have a little bit of knowledge and would like to learn more. I am right one this? Anyway, I asked about a community area to help, learn, etc... about learning PHP and what new standards are used in the new version. I mean I see so many things like Code Igniter, I think it is called, and others, that I am just confused. Maybe someone can guide us towards the right areas.

And I hope I am not wrong about you wanting to learn, etc... Maybe we can learn something by trying to modify this open source VA Forum. I really don't know. Not even sure if I can really grasp the concept of PHP, but I think I can eventually :)

If so disregard this!

Thanks,

DJ

Share this post


Link to post
Share on other sites

Hi Dj. I am always trying to learn something new and phpVMS is a great avenue to do so.

I have been to college for this stuff but the school sucked so I really didn't learn anything much. I am not sure what code igniter or any of that other stuff is sadly enough. When I do go try to learn, people talk to me like I am a wizard already and know every vocabulary word and can get right to it when that in fact is not so at all. We are all beginners and some of the gurus forget that little fact. But I am always willing to learn.

As far as this forum goes, I would love to continue it and get it whooped in to shape. I know there is a pay version here  and it is very well worth the money being asked for it but my wallet just don't allow payware for a VA that I don't know if it will ever take off ( no pun intended ). It is $53 USD. Since this one is currently free, I fiddle with it here and there and see what I can do with it. If it gets to be to much for me, I'll just go grab phpBB3 or SMF or something like that. On a side note, it would be great if we could get this coded up like a regular forum almost and it be included in phpVMS as default. I can't imagine any VA out there running phpVMS that does not have a community board built in somehow.

Have to run for now, my phone is ringing ... again.

Take care and I'll catch up to you on the dev thread and we can see what is up maybe we can scare up some support and figure things out.

Ray

Edited by TAV1702

Share this post


Link to post
Share on other sites

Getting this error when trying to add a new board or edit a board

Fatal error: Uncaught ArgumentCountError: Too few arguments to function ForumData::edit_old_board(), 4 passed in /home/losyhkv/www/phpvms/core/modules/Forum/Forum.php on line 550 and exactly 5 expected in /home/losyhkv/www/phpvms/core/common/ForumData.class.php:62 Stack trace: #0 /home/losyhkv/www/phpvms/core/modules/Forum/Forum.php(550): ForumData::edit_old_board('16', 'My First Forum', 'Edit me! Do not...', '1') #1 /home/losyhkv/www/phpvms/core/modules/Forum/Forum.php(40): Forum->edit_old_board() #2 /home/losyhkv/www/phpvms/core/classes/MainController.class.php(218): Forum->index() #3 /home/losyhkv/www/phpvms/index.php(70): MainController::RunAllActions() #4 {main} thrown in /home/losyhkv/www/phpvms/core/common/ForumData.class.php on line 62

 

Edited by miniarma
Managed to fix the issue myself, the Forum.php file was not including the $forum_order call

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...