Jump to content

Leave Of Absence v0.9


Sava
 Share

Recommended Posts

The version is 1.0, the last one available. It was throwing more errors as already described by many members in different posts and I

cleaned them all up.

The only thing which still does not work is the error thrown when we try to delete a LOA request. That error is connected to the function

in Line 63 that Sean had posted about. Basically, it's not talking to the DB and the function needs to be rewritten, but I didn't have time.

Link to comment
Share on other sites

That's part of the problem. We cannot use php 7.2 as it breaks other things.

This VA is running on 20+ different add-on modules and I don't have to explain any

of you what a headache it is to make them all work together nicely. 😉

Edited by William
Link to comment
Share on other sites

Yes, I'm sure you did, but with over 200 active pilots, I'm not about to go fiddle with things that can break the site and create bigger problems unless I have to, especially over something small like LOA requests that I can easily delete straight from the DB. Also we have add-on nobody else does so it's hard to compare.

Anyway, thanks for looking into it

Edited by William
Link to comment
Share on other sites

  • 5 months later...

Hello Guys, does the feature which checks if the pilot has already submitted an loa works for you?

For us it didn't but i don't know why...

Here our files.

Many thanks in advance for your help.

BRGDS Thomas

 

 

LoaData.PNG.45fd00034590ad03f5e7b3f4423c0d82.PNG

 

***********************************************************************************************************************************************

 

LOA.PNG.95688de92ffc0dc4c05ad7d0e19635b5.PNG

 

Edited by Thomasha
Link to comment
Share on other sites

  • Administrators
4 hours ago, Thomasha said:

Hello Guys, does the feature which checks if the pilot has already submitted an loa works for you?

For us it didn't but i don't know why...

Here our files.

Many thanks in advance for your help.

BRGDS Thomas

 

 

LoaData.PNG.45fd00034590ad03f5e7b3f4423c0d82.PNG

 

***********************************************************************************************************************************************

 

LOA.PNG.95688de92ffc0dc4c05ad7d0e19635b5.PNG

 

 

What version of phpVMS are you using?

Did you run the SQL file to add to the database? This adds a new table for the LOA module.

 

Link to comment
Share on other sites

  • Administrators
1 hour ago, LuxuryCEO said:

the module on my site says theres a critical update with a yellow box 😕

 

 

Just ignore it. If it really bothers you, you can edit the module files to remove the check for updates. Of course, back up the originals before messing around with it.

  • Like 1
Link to comment
Share on other sites

On 12/31/2020 at 2:29 AM, ProAvia said:

 

What version of phpVMS are you using?

Did you run the SQL file to add to the database? This adds a new table for the LOA module.

 

We are still on Version 2.1.v2.1.935.

This module is working since years for us. If you refer to the "hub"... i added this manualy to the database.

I also cross checked the installer file with our actual table and they are all correct.

We now also saw that the "delete" function also don't works anymore 😞

Unbenannt.PNG

Link to comment
Share on other sites

  • Administrators
5 hours ago, Thomasha said:

We are still on Version 2.1.v2.1.935.

This module is working since years for us. If you refer to the "hub"... i added this manualy to the database.

I also cross checked the installer file with our actual table and they are all correct.

We now also saw that the "delete" function also don't works anymore 😞

Unbenannt.PNG

 

The "You already have an LoA on file...." works on mine.

 

I don't know anything about the loa table having a hub entry. Mine doesn't have hub - but does have status after reason.

 

What PHP version are you using?

What MySQL/MariaDB version?

 

Link to comment
Share on other sites

PHP-Version: 5.6.37-1+ubuntu16.04.1+deb.sury.org

MySQL: Server-Version: 5.7.23-0ubuntu0.16.04.1

 

I don't know the version with "status" in the table. What does this status show? Is this file anywhere for download?

The Hub entry was inserted by ourself. When the pilot is sending the loa its copied out of Auth::$userinfo and entered in this table so that it can be displayed in the loa admin

Link to comment
Share on other sites

  • Administrators

In looking at my original module files and what is on my site, I have no idea where the status column came from or what it actually does. It may have something to do with my pilot manager module, which hasa column to mark pilots on leave. If I find out I will post back here.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...