Jump to content
Vangelis

Sim Brief for phpvms

Recommended Posts

Most propably the problem might be because you are using free hosting as simbrief is linking back to the website the rest as i see it is corect

Share this post


Link to post
Share on other sites

Hello , just one question all works perfect for me on two va's , im wonder if is possible to change the name when saving flight plan for ex. my fligt plan for PMDG is now - EPGDEPWA_PMR_1427875235.rte , i woudl like to have like PFPX do for example - EPGDEPWA01.rte. Where i can change that.

Share this post


Link to post
Share on other sites

Good evening everyone.

When the site changes, the API also changes?

I changed to a paid hosting with a domain name.

It did not work before, I think that the it should work! I Do Not?

What worried me is that when I click on the SIMBRIEF button, nothing happens ...

www.uasgroup.org

or

http://www.uasgroup.org/phpvms/index.php/schedules

Thank you for your answers.

Best Regards.

Patrice

Share this post


Link to post
Share on other sites

Yes I got it.

Derek answered me last night.

In fact he told me that the CODE API did not need changing.

Thank you.

Best Regards.

Patrice

Share this post


Link to post
Share on other sites

RE me ...

I advanced on the problem ....

I got the liaison with the simbrief site, the green bar appears, it's going to the end, and then I have this:

Warning: include (core / codon.config.php) [function.include]: failed to open stream: No such file or directory in /home/site3948/web/www/index.php on line 40

Warning: include (core / codon.config.php) [function.include]: failed to open stream: No such file or directory in /home/site3948/web/www/index.php on line 40

Warning: include () [function.include]: Failed opening 'core / codon.config.php' for inclusion (include_path = '.: / Usr / local / php-5.2.17 / lib / php') in / home / site3948 / web / www / index.php on line 40

Fatal error: Class 'Config' not found in /home/site3948/web/www/index.php on line 42

Share this post


Link to post
Share on other sites

are the templates in the corect place ?

they should be located in /core/templates/SimBrief

if not you can contact me via skype and pass me over your ftp info and i can do it for you

Share this post


Link to post
Share on other sites

Hi All,

I have a problem, I have placed my key in the correct file and added all URL addresses however when i go to load up fight plan details the simbrief window opens and the status bar moves across in in green. It then directs me to a 404 error placement page. All URLS are correct. Another thing i notice in the browser (Chrome) the status bar in the bottom left says waiting for aerlingusvirtal.org momentarily then changes to the default www.mysite.com then goes straight to the 404 placement.

Share this post


Link to post
Share on other sites

That means that somewhere you forgot to add your webpage address reread the instructions and you will have to correct your airplane type as AT76 is not a correct airplane type as simbrief supports only AT72 airplane

Share this post


Link to post
Share on other sites

Hey,

Can you check this line in schedule_briefing.tpl? (line 195 on default)

<input type="button" onclick="simbriefsubmit('http://www.YOURSITENAME.com/index.php/SimBrief');" style="font-size:30px" value="Generate Simbrief">

Change YOURSITENAME aera in this code. If you do this, your simBrief module can work with your system.

Thanks.

Share this post


Link to post
Share on other sites

Hi, this is working smooth on my website. Just one problem though. Once generating the brief finishes and the template loads, the navigation on my web site appears like im logged out even though I'm still logged in. The nav bar changes the links.

Share this post


Link to post
Share on other sites

Hello Vangelis,

For some reason, the Generate Simbrief button is non-functional. Meaning it appears but once you click the button it simply does nothing. I have followed the readme included in your download and still no improvement. Any help would be greatly appreciated!

Share this post


Link to post
Share on other sites

Usualy that happens when you have not corectlyattached the javascript file

If you want tell me your site and i can have a look at it

Share this post


Link to post
Share on other sites

Hi guys,

I use this module and it works for our local flights.

I just wrote code using my flightAware API to get flights.

Those flights are not into my Database, so my question is: how I could use the Simdispatch (paperwork) link then show up like your simbrief module does?

EDIT: Everything works now using Simbrief module and my Flighaware API code.

Share this post


Link to post
Share on other sites

I dont think you read the whole instructions in the Readme.txt in the zip file step 5 says

5. Add this line before </head> tag in layout.tpl

<script type="text/javascript" src="<?php echo fileurl('lib/js/simbrief.apiv1.js');?>"></script>

That is what you are missing ;)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...