Jump to content

[SKIN] Disposable Theme (Current)


DisposableHero
 Share

Recommended Posts

Disposable Theme (Current)


*** IMPORTANT ***

 

This is the v3 series theme, it is compatible with latest Disposable Modules and phpVMS v7 dev builds released after 01.DEC.21

Please check the online readme file from GitHub for update process.


 

  • Like 1
Link to comment
Share on other sites

  • 4 weeks later...
56 minutes ago, 634Spaceman said:

I can't get this to update at all. I've followed the instructions and can't figure out what's wrong. I've attached the logs.    http://www.crew.guardianair634.com/storage/logs/laravel-2021-12-19.log

 

Nobody can reach that log with that link, it is not possible. Either download your log, pack it (zip,rar,7z etc) and upload somewhere with "public" access or just copy & paste the error part please.

 

And by "update" what do you mean ? You already have Disposable Theme v3 installed/working but can not update to its latest version or something else ? (Asking this because Disposable Theme v3 is NOT an update over v2, it is a new theme)

Link to comment
Share on other sites

59 minutes ago, 634Spaceman said:

sorry about that, here's the log at google drive https://drive.google.com/file/d/1MyJaJXNLBYncrAgrsJuiW3qadyEdYNaP/view?usp=sharing

 

by update I mean I tried to switch from V2 to V3 following the provided instructions and had no luck. It just provided an 500 server error

 

 

Looks like you simply skipped reading (or read but ignored) the basic requirements part of Disposable Theme v3 'cause this can only happen with a non-updated (or not properly updated) phpvms v7.

 

[2021-12-19 21:46:03] production.ERROR: Call to undefined method App\Models\Aircraft::simbriefs()

 

This important info is at the top of the readme

 

Theme is NOT compatible with beta4 or earlier development builds of phpVMS v7 prior to 14.DEC.21
Minimum required phpVMS v7 version is phpVms 7.0.0-dev+211214.c12cf0

 

So, if you update your phpvms to latest development build available as of today, I think you will be able to install and use Disposable Theme v3.

 

Be advised though, there is another note in the readme about module compatibility, so you need to update your modules too.

 

Theme is NOT compatible with older seperate Disposable addons, it is designed to be fully compatible with Disposable v3 series addons (Basic and Special as of date)

 

Good luck with the updates.

Link to comment
Share on other sites

  • 4 weeks later...
4 hours ago, Jbaltazar67 said:

Hello ,

 

Is it possible to see online flights on IVAO or VATSIM in the dashboard instead of No online flights found?

 

Sorry, do you want to see ALL online flights of IVAO and VATSIM at your dashboard ?

 

If you setup your phpvms user profiles and your theme (or the widget itself) properly it shows online flights of YOUR PILOTS only (IVAO and VATSIM). Displaying ALL flights is not a good idea at all.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...