Jump to content

Aircraft add


reed0427
 Share

Recommended Posts

  • Administrators

That's because your hosting is on MariaDB 10.2.

phpVMS 5.5.2.72 has issues with importing with MariaDB 10.2

 

There is no solution at this point - except direct manipulation of the DB. This isn't for the faint of heart and shouldn't be attempted if you don't know exactly what you are doing. And you should back up the DB before even attempting.

Link to comment
Share on other sites

  • Administrators

1 - quit changing/adding aircraft, schedules, etc. every 6 months

2 - direct DB manipulation - use caution with this

3 - start planning to upgrade to phpVMS v7 - a big undertaking given your present operation

4 - you already know the other option you've used in the past

 

Link to comment
Share on other sites

I liked option 3. Given the fact that v7 offers multi airline out of the box and its flexibility for setup and usage, it may be a nice choice for future. Schedules, fleet, operations etc all can be multi airline and if needed relaxed or easily can be restrictive upon airline needs. (costly, needs vmsAcars license)

 

Option 2 looks like the easiest solution, if the operator has enough database knowledge and have backups for worst cases. (free but risky, can be easy if you have enough knowledge)

 

Option 1 is the easiest :)

Link to comment
Share on other sites

It is due to strict mode, there is a work around which i found that works, but it is not ideal. You just need to add IGNORE to all INSERT statements and it should work. If you have a VPS or dedicated you can turn strict mode off. You can ask your host to turn strict mode off, but 9 times out of 10 they won't do that as it can cause problems for other web sites that share the server your site is on.

Link to comment
Share on other sites

  • Administrators
22 hours ago, Strider said:

It is due to strict mode, there is a work around which i found that works, but it is not ideal. You just need to add IGNORE to all INSERT statements and it should work. If you have a VPS or dedicated you can turn strict mode off. You can ask your host to turn strict mode off, but 9 times out of 10 they won't do that as it can cause problems for other web sites that share the server your site is on.

 

It's more than just a Strict Mode issue. Strict Mode is OFF in the MariaDB 10.2 instance he uses. It probably has more to due with an empty value in the default aircraft table for this specifc instance.

 

Shared hosting is being used and Strict Mode has been verified as OFF by his host.

 

But it's possible a similar hack will work - at least in the short term.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...