Jump to content
LeonardIGO4036

[SKIN][Free] iCrew LITE skin 2018 designed for phpVMS

Recommended Posts

Hello fellow VA Admins,
I am taking a very great pleasure to announce that iCrew LITE is finally hitting the arena. I initially planned to have this as a payware release, but i wanted to give back something to the community which helped me gain alot of knowledge in coding. Seriously, i owe you guys big time :) That is why i have released this as a freeware release. 

This Crew Center was designed using the Twitter Bootstrap framework, by far the best platform which works spectacularly on all your devices, and such devices include your PC, Tablet, iPad, iPhone, Android mobile phone etc. I have tried my best to make sure this Crew center is dynamic, which means everything happens automatically without you having to change/monitor something all the time. 

There are some internal tweaks here and there, some main things I've modified are, The New Feed. Now each of your News will come in the feeds with a "#", Example : "New Hub Added" will be displayed as "#newhubadded", I managed to fetch the METAR and Charts for all the Airports using cURL method, and also, I've added a nice little animation of getting the live METAR as a cherry on top ;), and I've also managed to add a simple "Focus Airports" module too. I guess this is enough for this forum post :P

If you have any issues, anything at all, don't hesitate to disturb me, I'm always open for help :) 


DOWNLOAD : 

You can download it directly from my GitHub repository, (Click here)

INSTALLATION : 

Simply follow what the documentation says, to make it as easy as possible, I've also included an installer along with documentation. (In short phpvms-Dummy-Friendly :P )

SCREENSHOTS : 


1.jpg

focusairport.pngevents.jpgmail.jpgschedule_briefing.jpg
 

Edited by LeonardIGO4036
  • Like 2

Share this post


Link to post
Share on other sites
3 minutes ago, airplaneguy456 said:

@LeonardIGO4036 Im getting this error from the installer:

It Does Not Appear That The Flightboard Installer Has Been Placed In The phpVMS Application Root

Can you get the latest commit please ? 

I fixed some minor stuff. 

Share this post


Link to post
Share on other sites
1 hour ago, airplaneguy456 said:

@LeonardIGO4036 I get this error now:

It Does Not Appear That The iCrewLITE Installer Has Been Placed In The phpVMS Application Root

Again? 

Make sure you have pasted the files in the correct directory. This error is because the installer couldn't locate the ../core/codon.config.php 

You have installed phpVMS some other root other than /public_html ?

Share this post


Link to post
Share on other sites

[Free] iCrew LITE skin 2018 designed for phpVMS

View File

Hello fellow VA Admins,
I am taking a very great pleasure to announce that iCrew LITE is finally hitting the arena. I initially planned to have this as a payware release, but i wanted to give back something to the community which helped me gain alot of knowledge in coding. Seriously, i owe you guys big time  That is why i have released this as a freeware release. 

This Crew Center was designed using the Twitter Bootstrap framework, by far the best platform which works spectacularly on all your devices, and such devices include your PC, Tablet, iPad, iPhone, Android mobile phone etc. I have tried my best to make sure this Crew center is dynamic, which means everything happens automatically without you having to change/monitor something all the time. 

There are some internal tweaks here and there, some main things I've modified are, The New Feed. Now each of your News will come in the feeds with a "#", Example : "New Hub Added" will be displayed as "#newhubadded", I managed to fetch the METAR and Charts for all the Airports using cURL method, and also, I've added a nice little animation of getting the live METAR as a cherry on top , and I've also managed to add a simple "Focus Airports" module too. I guess this is enough for this forum post 

If you have any issues, anything at all, don't hesitate to disturb me, I'm always open for help.

INSTALLATION : 

Simply follow what the documentation says, to make it as easy as possible, I've also included an installer along with documentation. (In short phpvms-Dummy-Friendly )

Happy New Year Gentlemen! 


 

Share this post


Link to post
Share on other sites

Okay, so did you create a subdomain ? 

When you create a subdomain, you would need to point it at a specific folder. So that folder would be named iCrew (or pretty much of your choice)

 

Share this post


Link to post
Share on other sites

Okay, so what is happening to everyone, is that we follow your "so simple directions" but we keep getting iCrewLITE Installer not found, or if you just extract the skin to the lib/skins folder, only the modules that you told us to get show, for example, when you click on dashboard it just says news in HTML, or when you click dashboard, it just takes you to this blank webpage the says your name, and active time...But, no one can try another way, as the installer is broken, it will not pick up all the installation files in the MAIN PHPVMS, like the directions said...

Share this post


Link to post
Share on other sites
13 hours ago, Jonah0037 said:

Okay, so what is happening to everyone, is that we follow your "so simple directions" but we keep getting iCrewLITE Installer not found, or if you just extract the skin to the lib/skins folder, only the modules that you told us to get show, for example, when you click on dashboard it just says news in HTML, or when you click dashboard, it just takes you to this blank webpage the says your name, and active time...But, no one can try another way, as the installer is broken, it will not pick up all the installation files in the MAIN PHPVMS, like the directions said...

If you have the basic knowledge, then yes, paste the files under lib>skins and you'll be good. 

And I did check the installer with 4 different domains. It worked perfectly, there is clearly something which everyone is missing out, I'll try to find out what it is at the earliest.

Share this post


Link to post
Share on other sites
5 hours ago, airplaneguy456 said:

@LeonardIGO4036 How would I point the installer to the specific folder where the codon.config.php file is located in?

 

You don't point the installer buddy. 

Have you installed phpVMS on a subdomain? If you are stuck with how to create one, follow this (http://support.hostgator.in/articles/cpanel/what-is-a-subdomain-name-how-do-i-create-and-delete-one

 

So, once you are creating a subdomain, it'll ask you to point a folder for the subdomain, at that time, put in a folder, for example 'icrew' and create the subdomain. 

Once that's done, you need to paste all of the files which you downloaded (It'll be one folder called iCrew LITE) into that folder which we newly created. 

No install phpVMS on to this subdomain. (Paste the phpVMS installer file and put the site URL as 'icrew.YOURVA.com' 

So the contents of the subdomain folder should have the following contents if you have installed phpVMS correctly, 

-icrew

--admin

--core

--lib

If you have these folders, just paste the iCrewLITE folder into the same. Now run the iCrewLITE installer or manually put them in lib>skins

Share this post


Link to post
Share on other sites

@LeonardIGO4036 I managed to install it but the page won't stop loading. I already added the lines to the local.config.php and installed the addons beforehand (except the Ranks module, I couldn't find that). How I installed it was weird because I had to put the install.php into the core folder along with the codon.config.php and I also had to transfer the documentation folder with it. 

Share this post


Link to post
Share on other sites
20 hours ago, LeonardIGO4036 said:

You don't point the installer buddy. 

Have you installed phpVMS on a subdomain? If you are stuck with how to create one, follow this (http://support.hostgator.in/articles/cpanel/what-is-a-subdomain-name-how-do-i-create-and-delete-one

 

So, once you are creating a subdomain, it'll ask you to point a folder for the subdomain, at that time, put in a folder, for example 'icrew' and create the subdomain. 

Once that's done, you need to paste all of the files which you downloaded (It'll be one folder called iCrew LITE) into that folder which we newly created. 

No install phpVMS on to this subdomain. (Paste the phpVMS installer file and put the site URL as 'icrew.YOURVA.com' 

So the contents of the subdomain folder should have the following contents if you have installed phpVMS correctly, 

-icrew

--admin

--core

--lib

If you have these folders, just paste the iCrewLITE folder into the same. Now run the iCrewLITE installer or manually put them in lib>skins

Um, It is the lack of explaining in the SO SIMPLE Directions!

Share this post


Link to post
Share on other sites

You're angry for this mate? Seriously? 

I sent it to 4 other people before making it available to the rest of the community, how come they didn't face any problem? Everyone has different levels of comprehending. If you are willing to help, then please try to make SIMPLE DIRECTIONS for the rest of the people too. I hope this doesn't come out the wrong way.

Share this post


Link to post
Share on other sites
15 hours ago, airplaneguy456 said:

@LeonardIGO4036 I managed to install it but the page won't stop loading. I already added the lines to the local.config.php and installed the addons beforehand (except the Ranks module, I couldn't find that). How I installed it was weird because I had to put the install.php into the core folder along with the codon.config.php and I also had to transfer the documentation folder with it. 

Contact me on PM, I'll do it for you. Sorry for the trouble you faced mate.

Share this post


Link to post
Share on other sites
6 hours ago, LeonardIGO4036 said:

You're angry for this mate? Seriously? 

I sent it to 4 other people before making it available to the rest of the community, how come they didn't face any problem? Everyone has different levels of comprehending. If you are willing to help, then please try to make SIMPLE DIRECTIONS for the rest of the people too. I hope this doesn't come out the wrong way.

Sure I'm willing, But the thing is that no where did it ever say move everything over to the core folder of phpvms, can you help me, becuase It is saying that I have no doc. or crewLITE installer found! But it does find phpvms and subdomain.

Share this post


Link to post
Share on other sites

So, I'm getting quite a weird outcome. I installed it, I didn't look right, so I installed the modules. It worked. I have made no further changes but now I try and all I get is basic HTML.

EDIT: Resetting skin to crystal then back to iCrew fixed the issue.

Edited by VirtualAirMalta

Share this post


Link to post
Share on other sites
5 minutes ago, VirtualAirMalta said:

So, I'm getting quite a weird outcome. I installed it, I didn't look right, so I installed the modules. It worked. I have made no further changes but now I try and all I get is basic HTML.

EDIT: Resetting skin to crystal then back to iCrew fixed the issue.

That's strange, but you used the installed or just did it all manually? 

I'm happy that it worked for you. If any assistance needed, contact me. 

Share this post


Link to post
Share on other sites
Just now, VirtualAirMalta said:

I installed it manually. It broke again when I tried to enter my edit profile page...

What exactly did you try to edit? 

Can you post a screenshot? 

Share this post


Link to post
Share on other sites

UPDATE : The Skin has been updated, and the installing instructions have been made more clear. I apologize for not being able to respond on time to few of you, I wish to state that i had met with a motorcycle accident and was unable to read all of your texts. To the People who have said that I've done a great job, Thank you so much for using and supporting iCrew. People who have messaged me regarding help, I guess I've got back to all of you. 


Get the latest commit from my GitHub, If anything goes wrong, feel free to text me up. I'll be available

Share this post


Link to post
Share on other sites
1 hour ago, lauriejd said:

Hi there,

Great fan of your skin. I need some help installing it. I try to do it manually but It doesnt seem to work.

Thanks,

Laurie

PM me the details, will check out ASAP. ;) 

Share this post


Link to post
Share on other sites

I have everything installed.  But when I log in or click on the Dashboard button it brings me to ../index.php/profile which returns a blank page with the exception of

Hello Wade, Welcome back to {airline}

access_time
Today's Hours
 
But if I were to type into the URL adding a /view/1 after profile it will bring me to my profile page nicely. 
 
???

Share this post


Link to post
Share on other sites
34 minutes ago, latitude24 said:

I have everything installed.  But when I log in or click on the Dashboard button it brings me to ../index.php/profile which returns a blank page with the exception of

Hello Wade, Welcome back to {airline}

access_time
Today's Hours
 
But if I were to type into the URL adding a /view/1 after profile it will bring me to my profile page nicely. 
 
???

I just fixed the errors with @lauriejd's VA. The problem is, either you haven't configured the StatsData.class.php or you haven't installed the rest of the modules which I've mentioned in the documentation. 

Make sure you've installed all the 5 add-ons which are required.

Share this post


Link to post
Share on other sites

Ugh, additional problems....  Registration page is goofed:

02.25.2018-18.07

Login Form is fine

i did put the recaptcha keys in. Reg form works on other skins. 

Edited by latitude24

Share this post


Link to post
Share on other sites
3 hours ago, latitude24 said:

Ugh, additional problems....  Registration page is goofed:

02.25.2018-18.07

Login Form is fine

i did put the recaptcha keys in. Reg form works on other skins. 

Ah, dont worry This was also a reported issue, and I resolved it a week ago :)

Get the latest commit from my repo. Or just get the code from this and replace it https://github.com/iCrewSystems/iCrewLITE/blob/master/iCrewLITE/registration_mainform.php

Share this post


Link to post
Share on other sites

Swapped it out same issue. 

There is something depreciated:  Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; ReCaptcha has a deprecated constructor in /core/lib/recaptcha/recaptchalib.php on line 42

Something with PHP7 I guess?

Edited by latitude24

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×