Jump to content
LeonardIGO4036

[SKIN][Free] iCrew LITE skin 2018 designed for phpVMS

Recommended Posts

Good afternoon, friends, I would like to congratulate the developers who are currently facilitating the creation of new projects.
My question is about how we can change the header on our page, how to change the color of the theme for an image?
aaa.png

Share this post


Link to post
Share on other sites

Hey buddy, thank you for your appreciation. 

Styling the skin is really simple. I've included this in the documentation, but just in case you missed it. 

"To change your theme, just simply go to lib > skins > iCrewLITE > layout.php and on line '79' theme-indigo change the "indigo" to your desired theme.

For your login background screen, for this release, you have to change it in each of the login_xyz.php and registration_xyz.php in the style tag."

Hope this helps! 

Share this post


Link to post
Share on other sites
13 minutes ago, LeonardIGO4036 said:

Hey buddy, thank you for your appreciation. 

Styling the skin is really simple. I've included this in the documentation, but just in case you missed it. 

"To change your theme, just simply go to lib > skins > iCrewLITE > layout.php and on line '79' theme-indigo change the "indigo" to your desired theme.

For your login background screen, for this release, you have to change it in each of the login_xyz.php and registration_xyz.php in the style tag."

Hope this helps! 

thanks for the reply, this information I had already read, I would like to know how can I change color to image, instead of being the color of the theme being an image

Share this post


Link to post
Share on other sites

Alright. That is actually pretty defined in the skin's css files. It's a very long process to add a new color all together, but I'll tell you a quick work around.

lib>skins>iCrewLITE>css>themes. Go there and select a color which you think will be the least preferable and open that theme-xyz.css 

You're going to find some css code with lots of "#" values. Those are called hex codes. So to change a color, you need to just replace the hex colors. 

To get a hex colors, go to Google and search for hex color picker. 

The best way is to Google the color given in the theme first, and then replace it (just so you know which color you're changing)

I understand that this is a bit long to follow up, but this would be the best that I could do for now. Hope this helps 

Regards

Share this post


Link to post
Share on other sites
On 6/30/2018 at 12:56 AM, loganq said:

Hi guys,

 

I"m slightly confused. I followed the installation instructions. The first section says:

Which is what I did. Then I followed the instructions as per the documentation.php file.

  1. Created the sub domain
  2. Removed my original installation from the root public_html folder
  3. Uploaded a clean set of files for phpVMS V5.5.x into the sub domain
  4. Ran the update.php script and completed the necessary fields
  5. Moved/copied the iCrewLITE folder into public_html/(subdomain_folder_name)/lib/skins
  6. Made the config and table change

While logged in everything looks great, right until you log out. Then you get this:

d554bbcdfc56911071d2790ec4394cdd.png

So that leaves me with THEE question....what did I do wrong?

 

Hi I would like to say thank you for all your hard work im loving this, i am also having this issue, i have read the documents to the letter and managed to get the logout page header pointed to the login page with "header('Location: '.url('/login'));" but for example

if someone is not a member and just visits the website to look around they see http://prntscr.com/l8jvoe  there are no menus or login or anywhere to click, also once logged in how do i get to the admin part of it ?  ie if i have admin powers and nobody else ?

thanks again for all your hard work..

 

Wazza

Share this post


Link to post
Share on other sites

Hello, 

I am getting an issue as well. I have installed phpvms and the skin, but now I am getting this error: 

Notice: The template file "/home/buskeitc/virtualairline/pilots//lib/skins/iCrewLITE/header.tpl" doesn't exist in /home/buskeitc/virtualairline/pilots/core/classes/TemplateSet.class.php on line 248

and on the bottom 

Notice: The template file "/home/buskeitc/virtualairline/pilots//lib/skins/iCrewLITE/footer.tpl" doesn't exist in /home/buskeitc/virtualairline/pilots/core/classes/TemplateSet.class.php on line 248

Also there is no CSS or any format. Check here: http://virtualairline.buske-it.com.ve/pilots/

Any ideas? 

Share this post


Link to post
Share on other sites
On 10/21/2018 at 12:12 PM, Booagce said:

Hi I would like to say thank you for all your hard work im loving this, i am also having this issue, i have read the documents to the letter and managed to get the logout page header pointed to the login page with "header('Location: '.url('/login'));" but for example

if someone is not a member and just visits the website to look around they see http://prntscr.com/l8jvoe  there are no menus or login or anywhere to click, also once logged in how do i get to the admin part of it ?  ie if i have admin powers and nobody else ?

thanks again for all your hard work..

 

Wazza

yes this is my problem too , help @LeonardIGO4036  us pleaseeee :((

Share this post


Link to post
Share on other sites
On 10/21/2018 at 2:12 PM, Booagce said:

Hi I would like to say thank you for all your hard work im loving this, i am also having this issue, i have read the documents to the letter and managed to get the logout page header pointed to the login page with "header('Location: '.url('/login'));" but for example

if someone is not a member and just visits the website to look around they see http://prntscr.com/l8jvoe  there are no menus or login or anywhere to click, also once logged in how do i get to the admin part of it ?  ie if i have admin powers and nobody else ?

thanks again for all your hard work..

 

Wazza

Hey Wazza, 
               It's nice to hear you're enjoying the skin. This skin, is made for VA's which use the 'dashboard portal', meaning only members with a valid login ID and password can access the contents of the VA. This is pretty much why i insisted the devs to install it on a subdomain like icrew.yoursite.com. 

Now that i see this is an issue, I am in the idea of developing a Front end theme too. Let's see where it takes us. If you have any freeware theme in mind which would be great for your VA, or if you have any suggestions to add, please go ahead. 

Regards

Share this post


Link to post
Share on other sites
On 10/26/2018 at 6:30 PM, bbuske said:

Hello, 

I am getting an issue as well. I have installed phpvms and the skin, but now I am getting this error: 


Notice: The template file "/home/buskeitc/virtualairline/pilots//lib/skins/iCrewLITE/header.tpl" doesn't exist in /home/buskeitc/virtualairline/pilots/core/classes/TemplateSet.class.php on line 248

and on the bottom 


Notice: The template file "/home/buskeitc/virtualairline/pilots//lib/skins/iCrewLITE/footer.tpl" doesn't exist in /home/buskeitc/virtualairline/pilots/core/classes/TemplateSet.class.php on line 248

Also there is no CSS or any format. Check here: http://virtualairline.buske-it.com.ve/pilots/

Any ideas? 

Hey, can you try checking if the skin is active? Go to Admin Center > General Settings > Skins and check if it's using icrew. 

Regards

 

Share this post


Link to post
Share on other sites

Hi,

thanks for the reply.

It is active. I had disabled it, since it did not work, in order to do some work on the site.

I have enabled it again. The error still exists. Feel free to have a look.

Cheers

 

Share this post


Link to post
Share on other sites
On 10/26/2018 at 9:00 AM, bbuske said:

Hello, 

I am getting an issue as well. I have installed phpvms and the skin, but now I am getting this error: 


Notice: The template file "/home/buskeitc/virtualairline/pilots//lib/skins/iCrewLITE/header.tpl" doesn't exist in /home/buskeitc/virtualairline/pilots/core/classes/TemplateSet.class.php on line 248

and on the bottom 


Notice: The template file "/home/buskeitc/virtualairline/pilots//lib/skins/iCrewLITE/footer.tpl" doesn't exist in /home/buskeitc/virtualairline/pilots/core/classes/TemplateSet.class.php on line 248

Also there is no CSS or any format. Check here: http://virtualairline.buske-it.com.ve/pilots/

Any ideas? 

Still the issue...

I have been checking here on the forums but no solution worked. There was one guy who had the same issue with crew center but never got his issue resolved or an answer to his question. So I am kind of stuck.

Share this post


Link to post
Share on other sites
On 25/11/2018 at 13:29, bbuske said:

Ainda a questão ...

Eu tenho verificado aqui nos fóruns, mas nenhuma solução funcionou. Houve um cara que teve o mesmo problema com o centro da equipe, mas nunca teve seu problema resolvido ou uma resposta à sua pergunta. Então eu estou meio preso.

I'm having the same problem here and no one answered yet, let's wait.

Share this post


Link to post
Share on other sites
On 12/26/2018 at 3:20 AM, Ernani1968 said:

I'm having the same problem here and no one answered yet, let's wait.

Hi 

I'm sorry that you had to wait this long, I was away for a while. 

Do you have the latest version of the skin?  

Are you running in phpVMS 5.5 2? 

Did you overwrite anything? 

The error says that phpvms was unable to locate header.tpl and footer.tpl.

That's weird because both of those files for this skin are named as app_top.php, app_sidebar.php and app_bottom.php. 

So somewhere within your phpVMS, the software. Is trying to load a different layout.php file, can you check if the layout file in the lib>skins>iCrewLITE folder is specific to the iCrew LITE format? (Should include atleast the word iCrew that page in some point, else it's the crystal skin's one. 

Share this post


Link to post
Share on other sites
On 12/30/2018 at 6:42 AM, LeonardIGO4036 said:

Hi 

I'm sorry that you had to wait this long, I was away for a while. 

Do you have the latest version of the skin?  

Are you running in phpVMS 5.5 2? 

Did you overwrite anything? 

The error says that phpvms was unable to locate header.tpl and footer.tpl.

That's weird because both of those files for this skin are named as app_top.php, app_sidebar.php and app_bottom.php. 

So somewhere within your phpVMS, the software. Is trying to load a different layout.php file, can you check if the layout file in the lib>skins>iCrewLITE folder is specific to the iCrew LITE format? (Should include atleast the word iCrew that page in some point, else it's the crystal skin's one. 

Hi,

happy new year. No worries.

I have been using phpVMS 5.5.2 indeed.

I have also checked the layout file layout.php. It is in the skins/iCrewLITE folder and it does seem to contain the correct paths. There are several paths in it, all containing iCrewLite.

Share this post


Link to post
Share on other sites
On 1/4/2019 at 11:32 PM, Maksim said:

Hello, As I can see there is a Focus Airport Module, How I can configure it, thank you very much!

Hey there @Maksim 

The module is extremely simple, no complex code at all. Which makes it almost a 'manual' module. 
When you want to add a new Focus Airport, simply go the focusairport folder in lib > skins > iCrewLITE and change the 'ICAO Code' and the 'Image'. As default, I've added 'OMDB' to be the Focus Airport.
Here's a Tip, (this is completely my opinion) use pictures which have tags like '#silhouette, #sunset' of famous monuments of the Airport's City. For example, i came up with this picture when I searched for 'Dubai skyline sunset silhouette'. 

 

Let me know if any other help is required

Share this post


Link to post
Share on other sites
On 1/4/2019 at 7:06 PM, bbuske said:

Hi,

happy new year. No worries.

I have been using phpVMS 5.5.2 indeed.

I have also checked the layout file layout.php. It is in the skins/iCrewLITE folder and it does seem to contain the correct paths. There are several paths in it, all containing iCrewLite.

Can you try a full delete and reinstall? 

Delete the skin, download the latest one and follow the documentation. 

If this is not helping, set me up with a demo account and your FTP details on PM. I'll do it for you. 

Regards. 

Share this post


Link to post
Share on other sites

Hello!

I know how to add a new ICAO and a new image. I dont know how to add this module to the main page of the site.

Thank you again!

Share this post


Link to post
Share on other sites

Everything else works well on the site but on the pilot profile, it shows this.

https://ibb.co/3NrHkyQ

Any ideas what I might have messed up?

Share this post


Link to post
Share on other sites

i have the same issues.

i see, thats a lot of pictures and scriptes not exists.

icreissue.JPG

GET https://cdnjs.cloudflare.com/ajax/libs/bootstrap-select/1.12.4/js/i18n/defaults-*.min.js net::ERR_ABORTED 404
bootstrap-select.js:157 Uncaught TypeError: Cannot read property 'valHooks' of undefined
    at bootstrap-select.js:157
    at bootstrap-select.js:1866
    at bootstrap-select.js:20
    at bootstrap-select.js:20
(anonymous) @ bootstrap-select.js:157
(anonymous) @ bootstrap-select.js:1866
(anonymous) @ bootstrap-select.js:20
(anonymous) @ bootstrap-select.js:20
(index):45 GET https://cdnjs.cloudflare.com/ajax/libs/bootstrap-select/1.12.4/js/i18n/defaults-*.min.js net::ERR_ABORTED 404
js?sensor=true:122 You have included the Google Maps JavaScript API multiple times on this page. This may cause unexpected errors.
sh @ js?sensor=true:122
Ah @ js?sensor=true:120
google.maps.Load @ js?sensor=true:18
(anonymous) @ js?sensor=true:210
(anonymous) @ js?sensor=true:210
admin.js:127 Uncaught TypeError: Cannot read property 'offsetTop' of undefined
    at Object.setMenuHeight (admin.js:127)
    at Object.activate (admin.js:99)
    at HTMLDocument.<anonymous> (admin.js:449)
    at j (jquery.min.js:2)
    at Object.fireWith [as resolveWith] (jquery.min.js:2)
    at Function.ready (jquery.min.js:2)
    at HTMLDocument.I (jquery.min.js:2)
setMenuHeight @ admin.js:127
activate @ admin.js:99
(anonymous) @ admin.js:449
j @ jquery.min.js:2
fireWith @ jquery.min.js:2
ready @ jquery.min.js:2
I @ jquery.min.js:2
jet.iflyva.in/lib/skins/iCrewLITE/images/favicon.png:1 GET https://jet.iflyva.in/lib/skins/iCrewLITE/images/favicon.png net::ERR_NAME_NOT_RESOLVED
common.js:119 Uncaught TypeError: Cannot read property 'prototype' of undefined
    at common.js:119
    at js?sensor=true:181
    at js?sensor=true:74
    at js?sensor=true:181
    at Fe (js?sensor=true:74)
    at Be.Zb (js?sensor=true:181)
    at common.js:1
(anonymous) @ common.js:119
(anonymous) @ js?sensor=true:181
(anonymous) @ js?sensor=true:74
(anonymous) @ js?sensor=true:181
Fe @ js?sensor=true:74
Be.Zb @ js?sensor=true:181
(anonymous) @ common.js:1
common.js:2 Uncaught TypeError: Cannot set property 'constructor' of undefined
    at Object._.bj (common.js:2)
    at util.js:214
    at js?sensor=true:181
    at Object.<anonymous> (js?sensor=true:74)
    at js?sensor=true:181
    at js?sensor=true:74
    at js?sensor=true:181
    at Fe (js?sensor=true:74)
    at Be.Zb (js?sensor=true:181)
    at common.js:1
_.bj @ common.js:2
(anonymous) @ util.js:214
(anonymous) @ js?sensor=true:181
(anonymous) @ js?sensor=true:74
(anonymous) @ js?sensor=true:181
(anonymous) @ js?sensor=true:74
(anonymous) @ js?sensor=true:181
Fe @ js?sensor=true:74
Be.Zb @ js?sensor=true:181
(anonymous) @ common.js:1
util.js:222 Google Maps JavaScript API warning: NoApiKeys https://developers.google.com/maps/documentation/javascript/error-messages#no-api-keys
ow.m @ util.js:222
(anonymous) @ js?sensor=true:120
Promise.then (async)
(anonymous) @ js?sensor=true:120
setTimeout (async)
Ah @ js?sensor=true:120
google.maps.Load @ js?sensor=true:18
(anonymous) @ js?sensor=true:210
(anonymous) @ js?sensor=true:210
util.js:222 Google Maps JavaScript API warning: SensorNotRequired https://developers.google.com/maps/documentation/javascript/error-messages#sensor-not-required
ow.m @ util.js:222
(anonymous) @ js?sensor=true:120
Promise.then (async)
(anonymous) @ js?sensor=true:120
setTimeout (async)
Ah @ js?sensor=true:120
google.maps.Load @ js?sensor=true:18
(anonymous) @ js?sensor=true:210
(anonymous) @ js?sensor=true:210
maps.googleapis.com/maps/gen_204?target=api&ev=api_alreadyloaded&client=&key=&cad=src:apiv3,token:5en0i6budb,ts:0zhr55:1 GET https://maps.googleapis.com/maps/gen_204?target=api&ev=api_alreadyloaded&client=&key=&cad=src:apiv3,token:5en0i6budb,ts:0zhr55 net::ERR_BLOCKED_BY_CLIENT

 

Edited by LightRO

Share this post


Link to post
Share on other sites

Hello, LeonardIGO4036 i want to thank you and your team so much, i have been looking for the opportunity to set up a VA for the west Africa Community of Simpilots and aviation enthusiats and at long last i settled on your Skin after haven searched and tried others i have confidently chosen yours for sure. God bless you so much.

I noticed after the installing i couldnt have access to the admin page. please is there anything you can do about ?...

I am also looking for a Hub manager module

 some fleet of aircraft aircrafts 

ACARS to start with 

if possible i will like you to text my installations and see if all is ok 

since you are the originator of the theme, i will like to keep a close contact with you for support and also i will be willing to donate a token for your hard work

our VA url is www.flywva.westafricavacc.org

Please browse through and advise me thank you 

Share this post


Link to post
Share on other sites

Hello LeonardIG4036, i have noticed my Google map is not working after setting it up, i guess you need to help me out 

thanks 

regards 

Edited by dannycomputers

Share this post


Link to post
Share on other sites

hello guys, i need the exact content in the iCrewLite logout.php file please

i messed up with mine, since then i can't access the site anymore 

Parse error: syntax error, unexpected '}' in /home/westafri/flywva.westafricavacc.org/core/modules/Logout/Logout.php on line 27

thank you 

Share this post


Link to post
Share on other sites
On 1/20/2019 at 11:32 AM, dannycomputers said:

Hello LeonardIG4036, i have noticed my Google map is not working after setting it up, i guess you need to help me out 

thanks 

regards 

Make sure that you have your google map api setup

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×