Jump to content

phpVMS 5.5.2.72 (phpVMS 5.5.2 updated for PHP 7.2)


ProAvia
 Share

Recommended Posts

  • Administrators
1 hour ago, SupernovaSurfer said:

Hello Avia ,

 

Thanks for the 5.5.2  updated code.  I've been maintaining a site using only the old code. I have only just managed to come across this version.

 

I had a question regarding the database , I have managed to install your version on a test site, as you mentioned in the readme there can be some errors.

 

Mainly I wanted to ask , is it possible to migrate the entire old database with the pirep records etc ?   To the database created for the install with your version

 

 

 

 

 

Is your present site on phpVMS 2.1.x or phpVMS 5.5.2 ?

Link to comment
Share on other sites

2 hours ago, ProAvia said:

After installing a fresh copy of 5.5.2.72, you can change the local.config to point to your existing 5.5.2 database.

 

What version of MySQL or MariaDB are you using?

 

MySQL 5.6  ,  I tried the local config edit and it populates most of the links fine , still some issues with some modules though, will have to work through as some are throwing errors

Link to comment
Share on other sites

  • Administrators

Great - MySQL 5.6 requires no changes to the table dynamics. As for the issues with some modules, that is something you will have to work through.

 

You may see errors referencing "count" in the error. These are pretty easy to fix. Use this closed issue reference in my github for an idea of what you may need to do: https://github.com/ProAviaAZ/phpvms_5.5.2.72/issues/40

 

Link to comment
Share on other sites

So most of the pages and links work fine but what has happened is that it is taking endlessly long to open the site main page and even the admin page .

 

I have to say that I've had the main page slow loading since the simpilot 5.5.2 ( if that's any indication to the cause).

 

However now even the admin page takes an endless amount of time to open, background errors I guess

 

All in all its fantastic though..thanks to your update Avia , I've managed to get back most of the functionality

 

 

Edited by SupernovaSurfer
Link to comment
Share on other sites

unknown.png

please need help, no acars shows latitude, longitude or altitude. I am in version 5.5.2.72 with the crystal skin that comes by default and the icon of my airplane in flight remains in latitude or longitude or the altitude in 0 also, php 7.0 and I have tested in 7.1 and 7.2 and it remains the same, I have bought the tracker position module thinking that this fixes the error but I still don't have the position of the real aircraft in flight. please help me

Link to comment
Share on other sites

  • Administrators

Your issue has nothing to due with the specific version (5.5.2.72) of phpVMS you are using. If it did, everyone else using that version would have the exact same issue.

 

You also have an error in your CC Flight Position Tracker that you will need to fix - after getting phpVMS working correctly. I would suggest removing the CC Flight Position Tracker until after you have solved this underlying issue.

 

I see you have another post about this issue elsewhere on the forum - I suggest you use that one for debugging your issue as the issue is not phpVMS 5.5.2.72 specific.

Link to comment
Share on other sites

  

 

So Avia the following also isn't related to using your version.

 

the solution you suggested worked perfectly fine, about pointing to the other database using localconfig.

 

 

There's been a core issue somewhere when I've migrated databases in the past from a different host. I wonder if you may have an idea about the probable cause.

 

If you see the image attached , against my pilot Id on the admin side I see no Airline attached , I see total count of pireps and hours but no pireps.in my record

 

When I point to the database from the clean install ( Your version - no localconfig hack)  ..its all ok no such issue.

 

Any thoughts about what could be the issue ?

 

jBGZtAT.png

 

 

Edited by SupernovaSurfer
Link to comment
Share on other sites

  • Administrators

I would guess that databases from a different server could cause issues. The database version number could be different or one could have been MySQL and the other MariaDB. Maybe many other variables as well.

 

Check the actual DB table to see if the Airline and Airport Hub are listed correctly. The other option may be to use the new database and transfer only the data over from the old database.

Link to comment
Share on other sites

It can happen the tables import, but the data isn't imported into those tables. I have seen it happen, it is a pain, if you have the database download, open the SQL file and find the relevant tables and copy the insert SQL and do it that way. When you imported the DB did you get any errors.

Link to comment
Share on other sites

 

 

 

Thanks  guys:

 

Avia yes have tried to edit the airlines table , tried lots of methods , create a duplicate table import data , data+structure etc ..got the inevitable key constraint errors ...all that😅

All that with only the 5.5.2 , however I still haven't tried "data only" to the new table after the new install, will try that today.

 

Strider thanks Db's  have been importing ok , and interestingly its only my record , majority seem ok. I can fly and the hours get logged all ok....you said it right..huuge pain !😊

 

Back at it......

 

Link to comment
Share on other sites

  • 4 weeks later...
  • Administrators
On 7/14/2020 at 9:03 PM, SupernovaSurfer said:

 

 

 

Thanks  guys:

 

Avia yes have tried to edit the airlines table , tried lots of methods , create a duplicate table import data , data+structure etc ..got the inevitable key constraint errors ...all that😅

All that with only the 5.5.2 , however I still haven't tried "data only" to the new table after the new install, will try that today.

 

Strider thanks Db's  have been importing ok , and interestingly its only my record , majority seem ok. I can fly and the hours get logged all ok....you said it right..huuge pain !😊

 

Back at it......

 

 

There are so many variables that it would be impossible to try to cover them all.

 

No telling why your record is messed up. I've also run into that key constraint error way too many times.

Link to comment
Share on other sites

9 hours ago, ProAvia said:

 

There are so many variables that it would be impossible to try to cover them all.

 

No telling why your record is messed up. I've also run into that key constraint error way too many times.

 

True Avia , your code solved most issues, the rest of the issues are my doing while moving hosts etc 😅

 

2 hours ago, Strider said:

Is the airlines table populated? If so, check the code for those to see if it is pointing to the right table. Have you edited any of the code recently? Also have you fixed the problem?

 

Strider thanks, yes it is populated , but you're right its probably a    airline code/pilot id  related thing , I probably messed that up in the past while dealing with the php version and hosting changes.

 

Thanks for asking Guys...so just for brainstorming...have a look at the following, see what gets mailed when a pirep is filed...issue highlighted in bold

 

A PIREP has been submitted by 0000 ( ) ...etc 

 

I'm trying to look at the pirepdata and pilotdata classes for that function return to analyze why it should return that 🙂

 

Its easy enough to start from scratch , but not giving up yet..I dont delete pilots..so its like 35000 pireps and over 100 thousand hours across 10 years.

 

 

Edited by SupernovaSurfer
Link to comment
Share on other sites

  • 4 months later...
  • Administrators

Is your host doing awaywith PHP 5.6? If not, no reason to use phpVMS 5.5.2.72

As you can see on your hosting, only PHP 5.6 and PHP 7.0 are available. Both versions are deprecated and no longer receiving updates. 

 

Are you having any issues with your present install?

 

I see your host is on MariaDB 10.3 - phpVMS 5.5.2.72 and 5.5.2 presently have some issues with MariaDB 10.2 and higher.

 

In any case, there is no direct upgrading of phpVMS 5.5.2 to phpVMS 5.5.2.72. You have to start with a fresh install of phpVMS 5.5.2.72, get all your modules and skin working error free and then move you data (only) from your 5.5.2 install over to 5.5.2.72. Do NOT just use your 5.5.2 database as is - there are database changes in 5.5.2.72 that are not in 5.5.2.

 

As for your present skin - it is not compatible with phpVMS 7 ... which has nothing to do with using PHP 7.0. It only has to do with what version of phpVMS you are using.

Link to comment
Share on other sites

  • 6 months later...

Now that PHP 7.0,1,2 is depreciated, going forward many hosts are providing PHP from 7.3 upwards only.  My question is what about an update to PHPVMS that works on 7.3 7.4 PHP as many things that were in the upgrade from PHP 5 to PHP 7 will have been fixed so it is quite possible that only a few items may need to be corrected or re-coded for the current version of PHP.  Actually I tried it on PHP 7.4 and there was a small error on EZDB CLASS  on installation but it completed , however there are a few errors that come up on the main screen.  What we can do is open up a topic and then post the errors as we go along and what the fixes are and then at the end we will have a PHP 7.3,4 version.  This would ensure that many virtual airlines can continue to use PHPVMS rather than transfer to VA BASE that is not free but works on PHP 7.4

 

 

Link to comment
Share on other sites

  • Administrators
9 hours ago, LesJar said:

Now that PHP 7.0,1,2 is depreciated, going forward many hosts are providing PHP from 7.3 upwards only.  My question is what about an update to PHPVMS that works on 7.3 7.4 PHP as many things that were in the upgrade from PHP 5 to PHP 7 will have been fixed so it is quite possible that only a few items may need to be corrected or re-coded for the current version of PHP.  Actually I tried it on PHP 7.4 and there was a small error on EZDB CLASS  on installation but it completed , however there are a few errors that come up on the main screen.  What we can do is open up a topic and then post the errors as we go along and what the fixes are and then at the end we will have a PHP 7.3,4 version.  This would ensure that many virtual airlines can continue to use PHPVMS rather than transfer to VA BASE that is not free but works on PHP 7.4

 

 

 

Your best option is to upgrade to phpVMS 7. It will work in PHP 7.3, 7.4 and 8.0

If you choose to upgrade, use the current phpVMS 7 dev build. Do NOT use beta 4.

You will NOT be able to use your phpVMS 2.x or 5.5.2 database.

Link to comment
Share on other sites

  • 3 months later...

Anyone able to get Sendgrid to work with this version? I am on a TFDi hosting plan and they are blocked by all Microsoft email servers. I have used Sendgrid effectively with 5.5.2 but as soon as I try to create a key and use if for 5.5.72 on php 7.3 it does not talk to sendgrid. 

 

Thank you,

 

-Ken 

Link to comment
Share on other sites

  • Administrators

5.5.2.72 is for PHP 7.0 thru 7.2

There may be issues on PHP 7.3 and above. No support can be given for PHP above 7.2 as I don't use those versions.

 

You may want to consider setting up a Gmail or Outlook account for site use if all email thru tfdi hosting is blocked by MS.

Link to comment
Share on other sites

  • 2 months later...

Good evening, I installed phpvms 5.5.2.72 with php version 7.2 but I have this problem:

 

Warning: mysqli::__construct(): Headers and client library minor version mismatch. Headers:50649 Library:50528 in /home/ta3xnt1x/public_html/phpvms5.5/core/classes/ezdb/ezdb_mysqli.class.php on line 101

 

I ask for help on how to solve, thanks to all

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...