Jump to content
ProAvia

phpVMS 5.5.2.72 (phpVMS 5.5.2 updated for PHP 7.2)

Recommended Posts

After much time and effort fixing errors, I now have phpVMS 5.5.2 working successfully on PHP 7.2. My live site has been running this for over 3 months. The installation program has now been updated to be able to install under PHP 7.2 as well.

After much testing, including by several members here, I decided to release this version to the community.  Here's a link to the program at github: https://github.com/ProAviaAZ/phpvms_5.5.2.72

Be sure to read the README file. Some may experience a few warnings when installing. While these warnings can be fixed, doing so creates major issues elsewhere with the installation. Continuing with the installation will install the program successfully. Additionally, this version may install under PHP 7.0 and PHP7.1 - but has not been extensively tested. It will NOT install under PHP 7.3 or higher.

Some existing addon modules may need additional tweaking to get them working correctly with phpVMS version 5.5.2.72 - this is due to changes in PHP 7.2

Thanks to those members who helped test this for me. And thanks to Nabeel for permission to make this version available to the community.

 

Edited by ProAvia

Share this post


Link to post
Share on other sites

Our Hats are off to you for sure ProAvia,

Thank you for the chance to help even just a little bit, and to be Honest, I am much impressed with this. Outstanding job for sure. I know myself how much time and work it takes just developing Skins for version 5.5.2.xx. Its not at all easy for even the Advanced Web Master at heart. I am sure I speak for a lot here when I say thank you, thank you for your Hard Work, and dedication to our Cause in helping with something that most of Love at heart, PHPVMS !

Thanks Again Pro Avia

Jim "Heritage1"

Share this post


Link to post
Share on other sites

I downloaded this and installed it and it works amazingly well except for the registration page.

It just reloads with no registration info being transmuted

Any ideas?

Thanks 

Rick

P.S.

Thanks for this I can't seem to find a good copy of V2

Edited by Captthud
wrong problem

Share this post


Link to post
Share on other sites
  1. What version of PHP, Apache and MySQL are you using?
  2. Are you using MySQL or MariaDB? If MariaDB, what version?
  3. Site URL?
  4. Did you use a valid email for the admin email address?
  5. Have you tried using the Contact form to see if an email is sent?  SITE_URL/index.php/contact
  6. Do you have ReCaptcha set up correctly?

Share this post


Link to post
Share on other sites

1. PHP 7.2.15, Apache 2.2x, MySQL 5.6 on a Debian platform.....not sure what version

2. I'm using MySQL

3. http://www.ich.flyvfrwpr.com/ich/index.php

4. Yes even when I tried to register as another person both email addy's are valid

5.not until you suggested it, and it works

6.As far as I know the ReCaptcha it's working just like it should I had to verify with ReCaptcha when I sent myself an email

The install was flawless, I've added a couple modules, and they work just as expected

I was thinking it's because I'm trying to register using the same ip on the client side

I'm pretty stumped here, been google'in for a couple days

Thanks for the quick response

Rick

Edited by Captthud

Share this post


Link to post
Share on other sites

Using the same IP shouldn't matter. ReCaptcha is working fine.

I registered and submitted a contact under Joe Blow. Did you get an email for either of them?

Is error logging turned on? Is there anything in the error logs?

Share this post


Link to post
Share on other sites

Yes I got both of them

Did you get the acceptance email for both

You should have gotten a notice of an internal email from bot of them as well

I don't see anything in the server logs

I don't believe I have error logging turned on, but it seems to be working fine except I can't create another account I just tried again, and it just reloaded the page.....could it be my browser cache I have logged in as the admin on my other computer

Thanks

Rick

Share this post


Link to post
Share on other sites

Well - I used a bogus email address, so I won't be getting an email. 😉

Certainly won't hurt to clear your browser cache - or try with a different browser.

On my host, I needed to create a '.user.ini' file to turn error logging on in php7.2 - contents below

; see https://maximivanov.github.io/php-error-reporting-calculator/ for error reporting level calculator
; E_ALL & ~E_NOTICE = 32759 - all errors except notices
; E_ERROR | E_WARNING | E_CORE_ERROR | E_CORE_WARNING | E_COMPILE_ERROR | E_COMPILE_WARNING | E_RECOVERABLE_ERROR = 4339
; log_errors_max_len - 1024 is default, 0 is unlimited
error_reporting = 32759
display_errors = On
display_startup_errors = Off
log_errors = On
log_errors_max_len = 0
error_log = <FULL_PATH_TO_phpVMS_DIRECTORY>/error_log
; FULL_PATH... may start with /home/<NAME>/public_html/<phpVMS_location>/errorlog

Notice that I wanted to see all errors except Notices and that I want an unlimited error_log file length/size.

You can make this file in notepad or another plain text editor. Name it '.user.ini' and upload to the php VMS directory. Also make an empty file named 'error_log' and upload to same location.

Some hosts may not require you to do this, but may need to have error logging turned on. Having the error logging on will also help you find other errors in modules, etc.

EDIT: May I ask why you aren't using the most current version of kACARS_Free? Versions 1.0.1.4 and 1.0.1.5 are very stable - http://www.fs-products.net/index.php/kacars-free/downloads-2

Edited by ProAvia
kACARS_Free

Share this post


Link to post
Share on other sites

No worries..... done that myself more than once. LOL

And if you want pilots to use a specific client version, in /core/modules/kACARS_Free/kACARS_Free.php line 33 - set that to the version you are using and line 34 to yes.

You can host the kACARS_Free file on your site also if you wish - just show a link back to FS_Products. That will avoid confusing your pilots with multiple versions.

So, the registration email issue is solved??

 

Edited by ProAvia

Share this post


Link to post
Share on other sites

yes now I have a disappearing act, the 2 text boxes in the log in the area at the top of the page just went away.....all on their own.....lol

Edited by Captthud

Share this post


Link to post
Share on other sites

Make sure you are logged out of the site. They aren't there is logged in. I just checked your site and they are visible when logged out.

Share this post


Link to post
Share on other sites

I'm getting this error when I edit a pilot on the admin side

/hermes/bosnaweb15a/b82/ipg.rtpianogcom1/ich/admin/modules/PilotAdmin/PilotAdmin.php on line 135

When I try to edit a pilot group I get the module Pilotadmin doesn't exist

I also can't seem to edit the text in the navbar

Rick

Edited by Captthud

Share this post


Link to post
Share on other sites

You are trying to edit an existing pilot?

Is this the error?

Quote

Warning: count(): Parameter must be an array or an object that implements Countable

EDIT - I think I see the issue. I will address it tomorrow when I am back at the computer.

Go to my github and open a new issue - https://github.com/ProAviaAZ/phpvms_5.5.2.72/issues

Edited by ProAvia

Share this post


Link to post
Share on other sites

this is from the all pilots page after clicking on save changes   Warning: count(): Parameter must be an array or an object that implements Countable in /hermes/bosnaweb15a/b82/ipg.rtpianogcom1/ich/admin/modules/PilotAdmin/PilotAdmin.php on line 135

and this is from user groups when I click on edit https://www.dropbox.com/s/lj4mliz277p9x3z/error1 pic.jpg?dl=0                      

I already had this one going will go over to github next

Edited by Captthud

Share this post


Link to post
Share on other sites
19 hours ago, Captthud said:

this is from the all pilots page after clicking on save changes   Warning: count(): Parameter must be an array or an object that implements Countable in /hermes/bosnaweb15a/b82/ipg.rtpianogcom1/ich/admin/modules/PilotAdmin/PilotAdmin.php on line 135

and this is from user groups when I click on edit https://www.dropbox.com/s/lj4mliz277p9x3z/error1 pic.jpg?dl=0                      

I already had this one going will go over to github next

Should be fixed now. Update or download the /admin/modules/PilotAdmin/pilotAdmin.php file from the github repository.

https://github.com/ProAviaAZ/phpvms_5.5.2.72/issues/48

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...