Jump to content

Nabeel

Administrators
  • Content Count

    7896
  • Joined

  • Last visited

  • Days Won

    9

Everything posted by Nabeel

  1. Yeah, fair enough. Check out the docs for the new one: http://docs.phpvms.net/developers/add-ons-and-modules I could use help with making fixes to the code or better docs, though.
  2. zfw is an optional value for the aircraft/subfleet
  3. Are you looking to do this for the new/upcoming version?
  4. Can you send me the full request and response headers? I will take a look tonight.
  5. Is there anything in the browser error console?
  6. If you create a php info page, does it show as running on PHP 7.1 as well? That line is the nullable type feature, and was new in 7.1: http://php.net/manual/en/migration71.new-features.php#migration71.new-features.nullable-types
  7. Nabeel

    Installation issue

    Not without seeing that line. Is this phpvms 7 or a different version?
  8. That's a code error on their part
  9. Problem was the .htaccess file needed this line, under the "RewriteEngine On" line RewriteBase / I've fixed it in the next dev version, but posting it here FYI for anyone else looking
  10. If you're on PHP 7.0 it will mostly work, but you might run into some issues.
  11. Hey, it's not released just yet It looks like the stylesheets aren't loading. Is there a URL I can look at? Did the installer look fine? Who's your webhost, is it shared hosting?
  12. At this point it'll require a reinstall. But from the beta on, I'm hoping that just uploading the files and then going to the update URL will suffice.
  13. The joindate probably isn't in the SELECT clause for those other pages
  14. Hi everyone! The 2nd alpha version is available for people to test and play with: Download: https://github.com/nabeelio/phpvms/releases/tag/v7.0.0-alpha2 Docs: http://docs.phpvms.net The biggest changes are that PHP 7.1 is required now. There are tons of bug fixes and extra features, which are documented in the changelog, and some things to make things easier, based on feedback. Bugs, etc, should posted in the issue tracker on Github. The next release will be a beta version, with finances working, and hopefully finalized all features for a major release. No, I don't have a timeline *NOTE* ATM, there are no ACARS compatible. The API won't be changing much, so see the docs if you're wanting to develop your own ACARS application, or to update yours to add compatibility: http://docs.phpvms.net/developers/acars
  15. Awesome! Maybe something didn't get uploaded properly.
  16. This means that the rewrite rules aren't working. Does your host use Apache? Make sure that the htaccess rules are active, sometimes you need to enable it in an admin panel or something.
  17. That's kind of out of scope for someone to help you with here. You'll have to contact your host, or if it's your own server, you can google some guides for your OS
  18. Can you try the latest dev version, just do a fresh install, delete the env.php and config.php http://downloads.phpvms.net/phpvms-v7.0.0-dev.tar.gz
  19. You can clone it on github and create the right lang folder for Chinese (which dialect do you speak?) and I'll look at the pull request. And you can amend it as needed.
  20. Who's your host? There is an error: [2018-02-04 11:25:47] dev.ERROR: putenv() has been disabled for security reasons {"exception":"[object] (ErrorException(code: 0): putenv() has been disabled for security reasons at /home/vol9_5/epizy.com/epiz_21535679/nair.cf/htdocs/phpvms/vendor/symfony/console/Application.php:924)
  21. Hey, you don't need to do this anymore
  22. There is, it's not complete yet: resources/lang. Probably after alpha2 I'll start integrating the lang stuff in the admin and other pages.
  23. There aren't any ACARS compatible yet. You can only file manually
×
×
  • Create New...